[jboss-user] [JBoss Seam] - Re: The Right Scope

JUnkie do-not-reply at jboss.com
Mon Jul 23 14:14:40 EDT 2007


Hi fhh,

as BookSearchAction.search is called from page 1 and displays page 2 after that I would call it a redirect... this is how page 1 and 2 look like:

Page 1:
<h:form>    
  |     <h:inputText value="#{searchRequest.keyword}" size="20"/>    
  |     <h:commandButton value="#{msg.search}" action="#{bookSearch.search}" class="button"/>    
  | </h:form>

Page 2("searchResultsPage"):
<h:dataTable class="dataTable" value="#{searchResults}" var="result" rendered="#{searchResults.rowCount>0}">
  |       <h:column>
  |         <b><h:outputText value="#{result.title}"/></b>
  | ...

View the original post : http://www.jboss.com/index.html?module=bb&op=viewtopic&p=4066775#4066775

Reply to the post : http://www.jboss.com/index.html?module=bb&op=posting&mode=reply&p=4066775



More information about the jboss-user mailing list