[jboss-user] [Installation, Configuration & DEPLOYMENT] - Cannot undeploy package after timeout

scubie do-not-reply at jboss.com
Mon Aug 25 07:51:57 EDT 2008

Hi All

I have searched but do not seem to be able to find similar symptoms to this one...

We are using JBOSS 4.0.3 SP1 on Solaris in our development and in the production environments by the customer.  The following ONLY happens at the customer site.  We have tried similating it in our development even with the customer's data, no luck, it just does not happen by us.

We have a query which is submitted to Oracle ( which normally returns within 2 - 3 seconds.  Even if it scans all 1 million records it still returns fairly fast.  However occassionally the query does not return and we eventually get a timeout in JBOSS after 300 seconds.  I have raised that to 1200 seconds already but still no go.  

When JBOSS times out like this, we cannot even undeploy the package and re-deploy it again.  Other packages running under JBOSS still continue, but this one does not respond anymore, does not process any further transactions and cannot be un-deployed.  We need to stop JBOSS as a whole and rerstart it then all carries on as if nothing happened.

We can then even request the exact same set of data (query) and then all will work for some time.  We have not been able to identify a pattern at all.

Any ideas please?

Thank you


View the original post : http://www.jboss.com/index.html?module=bb&op=viewtopic&p=4172273#4172273

Reply to the post : http://www.jboss.com/index.html?module=bb&op=posting&mode=reply&p=4172273

More information about the jboss-user mailing list