[jboss-user] [JBossWS] - Re: Abstract class as input Parameter in WebService

snair33 do-not-reply at jboss.com
Fri Apr 24 08:10:58 EDT 2009

I used SOAP UI (soapui.org) to send the web service requests and following code worked for me

  | <soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:ser="http://www.searchforce.net/oneplace-ws/services">
  |    <soapenv:Header/>
  |    <soapenv:Body>
  |       <ser:showItem>
  |          <!--Optional:-->
  |          <Item xsi:type="Tower" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
  |                <!--Optional:-->
  |                <itemName>Test items</itemName>
  |             </Item>
  |       </ser:showItem>
  |    </soapenv:Body>
  | </soapenv:Envelope>

This code worked with JBOSS 4.0.5 as well as JBOSS 4.2.3.
I do receive this exception on first try. I think the problem was in setting xsi:type correctly. 

View the original post : http://www.jboss.org/index.html?module=bb&op=viewtopic&p=4226617#4226617

Reply to the post : http://www.jboss.org/index.html?module=bb&op=posting&mode=reply&p=4226617

More information about the jboss-user mailing list