[jboss-user] [JBoss Microcontainer] - has anybody deploy CAS 3.4 on JBoss5 successfully ?

MiNG Jason do-not-reply at jboss.com
Tue Aug 3 04:52:51 EDT 2010

MiNG Jason [http://community.jboss.org/people/JasonMing] created the discussion

"has anybody deploy CAS 3.4 on JBoss5 successfully ?"

To view the discussion, visit: http://community.jboss.org/message/555585#555585

recently, i'm struggling for deploying jasig CAS 3.4.2 on JBoss 5.1.0 GA.

however, i can't deploy it successfully on JBoss5, the main reason is some jar libraries in war file conflict to the libraries in %JBOSS_HOME%\common\lib.

i tried to put a jboss-classloading.xml file in WEB-INF, make the class loader of the war file isolated, but still not working, the log4j will stop working after loading the log4j.xml.
if i remove the jboss-classloading.xml file from WEB-INF, the classess will conflict and cannot deploy.

if anybody has the same problem like me and you have already solved it, please tell me how to do, i really have no idea about this.

appreciate for your helping.


Reply to this message by going to Community

Start a new discussion in JBoss Microcontainer at Community

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.jboss.org/pipermail/jboss-user/attachments/20100803/e5dd74c0/attachment-0001.html 

More information about the jboss-user mailing list