[jboss-user] [JBoss Remoting] - Using sockets from JBoss AS?

Matthew Browne do-not-reply at jboss.com
Sun Nov 28 16:06:31 EST 2010

Matthew Browne [http://community.jboss.org/people/mbrowne] created the discussion

"Using sockets from JBoss AS?"

To view the discussion, visit: http://community.jboss.org/message/573284#573284

I am writing a web-app using the Seam Framework that needs to talk to a musical programming application called MaxMSP.

It seemed to me that JBoss Remoting was a good solution for this, and I have a standalone test application working that will talk to MaxMSP (MaxMSP allows you to write Java externals, and I was able to get a JBoss Remoting server to work well from within MaxMSP).

The problem is that when I tried to move the code for establishing the client connection and callback server to the Seam app, I got an EOFException "end of file" error message (thrown from line 877 of org.jboss.remoting.transport.socket.MicroSocketClientInvoker.java).

After some Googling I saw a comment that led me to believe that JBoss AS might be blocking the socket connection. Is it even possible to use sockets with JBoss Remoting from within Jboss AS?

I tried to use RMI instead and almost got it working but unfortunately that doesn't work from within MaxMSP...since MaxMSP has its own dynamic classloader and RMI also has a dynamic classloader, I think there's a conflict there based on the error I was getting. I came to this conclusion because I got the server code to work fine outside of MaxMSP (as a standalone app).

Any pointers would be appreciated.


Reply to this message by going to Community

Start a new discussion in JBoss Remoting at Community

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.jboss.org/pipermail/jboss-user/attachments/20101128/4635c1a2/attachment.html 

More information about the jboss-user mailing list