[jboss-user] [jBPM] - Re: problem about running jbpm5

Billy Bartels do-not-reply at jboss.com
Mon Jun 27 16:48:36 EDT 2011

Billy Bartels [http://community.jboss.org/people/billybartels] created the discussion

"Re: problem about running jbpm5"

To view the discussion, visit: http://community.jboss.org/message/612211#612211


Thanks very much for your quick reply!

Yes I just tried jBPM 5.1 and the problem was resolved!

However I've got a new issue about how to deploy a slightly complicated process. Please take a look at the following eclipse project

 http://community.jboss.org/servlet/JiveServlet/showImage/2-612211-16595/EclipseProject.png  http://community.jboss.org/servlet/JiveServlet/downloadImage/2-612211-16595/450-140/EclipseProject.png 
Basically in the process the first service task "Poll SQS Queue" is polling an Amazon SQS queue. The interface is a java class "org.jbpm.bpmn2.CreateDeleteSNS".

The JUnit test for the app is working inside the eclipse. But how should I proceed to deploy the whole app? I tried to add the process to guvnor and compiled the package in Guvnor, when I started it in jbpm-console it got similar exceptions as before. I also tried to export the whole app as a jar package and put it in \server\default\deploy\jbpm-gwt-console-server.war, it didn't work either.

Kris can you please tell me how I should deploy this kind of process? Is there an example app that I can follow?

Thanks very much!

Reply to this message by going to Community

Start a new discussion in jBPM at Community

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.jboss.org/pipermail/jboss-user/attachments/20110627/750c84c3/attachment.html 

More information about the jboss-user mailing list