[jboss-user] [jBPM] - Re: [jbpm5.1] Inconsistencies between Guvnor and jbpm-console

michelpohle do-not-reply at jboss.com
Tue Nov 29 10:13:24 EST 2011

michelpohle [http://community.jboss.org/people/michelpohle] created the discussion

"Re: [jbpm5.1] Inconsistencies between Guvnor and jbpm-console"

To view the discussion, visit: http://community.jboss.org/message/638897#638897


now I managed to see my process again. *In short, this is what I found out*:

* when a process is not visible in the jbpm-console, all the other processes in Guvnor's defaultPackage won't be as well
* all my processes that would not show up had loops out of gateway nodes in them. When I removed the gateways, the processes would show up, even if I re-introduced them afterwards
* I did not try if  any change of the semantic of the process would produce that result 

I still have no idea +why+ I can't see them on the first try though, as I completely clean out Guvnor's repository between changes (see below), so the bug you mentioned should not occur.

*Long story*:
In order to find out if my problem was linked to the bug you described, I minimized my process again, this time clearing the Guvnor repository after each change (i.e. stopping JBoss, deleting $JBOSS_DEPLOYMENTS/repository and $JBOSS_TEMP/*, restarting JBoss). After the first change (removing all Gateways), I could suddenly see the task and after re-introducing them, the task was still visible (i.e. in its original version). I tried to manipulate the circumstances of uploading and deploying in order to see why the process was visible, but found none of them had any influence.

Only when I added another process to the repository (already in the initial build), I would consistently see neither of them both. The only difference in the server logs is that in the unsuccessful case, the last log entries are these...

> 5:18:28,665 INFO  [stdout] (http-- INFO  29-11 15:18:28,665 (LoggingHelper.java:info:49)       Following assets have been included in package build: drools, Bargain, serviceTask, shopclient-1.0.0, webservice, WSCustomWorkItem, 15:18:37,244 INFO  [stdout] (http-- INFO  29-11 15:18:37,243 (NilAuthenticator.java:authenticate:35)    All users are guests.
> 15:18:37,245 INFO  [stdout] (http-- INFO  29-11 15:18:37,245 (RepositoryServlet.java:allowUser:113)     admin authenticated for rest api
> 15:18:37,246 INFO  [stdout] (http-- INFO  29-11 15:18:37,245 (PackageDeploymentServlet.java:execute:134)        PackageName: defaultPackage
> 15:18:37,246 INFO  [stdout] (http-- INFO  29-11 15:18:37,246 (PackageDeploymentServlet.java:execute:135)        PackageVersion: LATEST
> 15:18:37,247 INFO  [stdout] (http-- INFO  29-11 15:18:37,246 (PackageDeploymentServlet.java:execute:136)        PackageIsLatest: true
> 15:18:37,247 INFO  [stdout] (http-- INFO  29-11 15:18:37,247 (PackageDeploymentServlet.java:execute:137)        PackageIsSource: false
> 15:18:37,325 INFO  [stdout] (http-- jbpm.console.directory property not found
> 15:18:38,633 INFO  [stdout] (http-- Loading session data ...
> 15:18:38,705 INFO  [stdout] (http-- Error loading session data: java.lang.reflect.InvocationTargetException
> 15:18:38,705 INFO  [stdout] (http-- Creating new session data ...
> 15:18:39,111 INFO  [stdout] (http-- Successfully loaded default package from Guvnor

... while in the successful case, before "jbpm.console.directory property not found" would be this line...

> 15:13:27,114 INFO  [stdout] (http-- Loading process from Guvnor: ua.telepark.CustomItemWSTest

... and then several lines with exceptions because I didn't upload a diagram.

As it turned out, I couldn't see the second process even if there was no other process in the repository. But with another process that already worked before these problems began, I could see both. So I did to my second invisible process what I had done to the first: removing and reintroduce the gateways. The result was the same: the process was now visible as well.

Reply to this message by going to Community

Start a new discussion in jBPM at Community

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.jboss.org/pipermail/jboss-user/attachments/20111129/425d4a63/attachment-0001.html 

More information about the jboss-user mailing list