[keycloak-dev] Running KeyCloak in cluster mode

Muein Muzamil shmuein+keycloak-dev at gmail.com
Wed Sep 21 10:35:57 EDT 2016

Hi all,

I am trying to run KeyCloak in cluster mode with docker containers using
standalone-ha.xml but for me containers are not joining the same infinispan

I tried to follow following blog entry but not sure it is still valid.

I was trying to follow this to run multiple docker containers in cluster
with the latest images. But when I ran second keycloak container, I didn't
see this container joining the 1st cluster. I was seeing this in the log
for the second container.

[0m[0m12:31:56,385 INFO
[org.infinispan.remoting.transport.jgroups.JGroupsTransport] (MSC service
thread 1-2) ISPN000094: Received new cluster view for channel keycloak:
[saskeycloak-fbtit|0] (1) [saskeycloak-fbtit]

To get it working I had to update private interface in standalone-ha.xml to
use docker container's IP.

<interface name="private">
    <!--<inet-address value="${jboss.bind.address.private:}"/>-->
    <inet-address value="" />

Is that really needed or do we have a better way to get it working?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.jboss.org/pipermail/keycloak-dev/attachments/20160921/efe65f24/attachment.html 

More information about the keycloak-dev mailing list