[keycloak-user] Getting 'Failed to find provider' when attempting to set default SPI provider

Dmitry Telegin dt at acutus.pro
Fri Feb 1 15:03:29 EST 2019

Hello Jared,

I've just tried to deploy a dummy EmailSenderProvider to Keycloak 4.8.3.Final, worked perfectly including the default setting. Could you try deploying to 4.8.3 too?

Also I've been deploying as a JAR, not WAR. You could also try that and see if it makes any difference.

Good luck,
Dmitry Telegin
CTO, Acutus s.r.o.
Keycloak Consulting and Training

Pod lipami street 339/52, 130 00 Prague 3, Czech Republic
+42 (022) 888-30-71
E-mail: info at acutus.pro

On Wed, 2019-01-30 at 12:00 -0500, Jared Blashka wrote:
> I'm trying to use a custom Email sender provider with keycloak 3.4.3.Final
> but something isn't working correctly because keycloak fails to start up
> with:
> java.lang.RuntimeException: Failed to find provider serviceEmailSender for
> emailSender
> I'm deploying the provider via a war in the /deployments directory. I have
> the factory class listed in the
> META-INF/services/org.keycloak.email.EmailSenderProviderFactory file
> I've added this to the keycloak-server subsystem
>             <spi name="emailSender">
>                 <default-provider>serviceEmailSender</default-provider>
>                 <provider name="serviceEmailSender" enabled="true"/>
>             </spi>
> If I leave out the <default-provider> entry and restart the server I can
> see that the init() method is called on my EmailSenderProviderFactory
> implementation so as far as I can tell everything is configured correctly.
> But keycloak doesn't like when I try to set this provider as the default.
> Is there something I'm missing?
> Jared
> _______________________________________________
> keycloak-user mailing list
> keycloak-user at lists.jboss.org
> https://lists.jboss.org/mailman/listinfo/keycloak-user

More information about the keycloak-user mailing list