[weld-dev] Java SE extension

Emmanuel Bernard emmanuel at hibernate.org
Mon Nov 23 04:03:43 EST 2009


On 21 nov. 09, at 19:36, Gavin King wrote:

> On Sat, Nov 21, 2009 at 10:47 AM, Pete Muir <pmuir at redhat.com> wrote:
>
>> * I would prefer to not actually bootstrap Weld core inside the  
>> Weld constructor (I believe this should be an explicit step), hence  
>> the boot() method. We could rename this to initialize() for  
>> example. Opinions?
>
> Fine by me. Especially since that at some stage we will need to pass
> some kind of settings before booting.

Which probably means you don't want Weld to host both the  
configuration and the operation methods

WeldContainer weld = new Weld().initialize();
weld.instance().select(Foo.class).get();


More information about the weld-dev mailing list