[jboss-dev-forums] [Design of Clustering on JBoss (Clusters/JBoss)] - Re: JBAS-4276 Discussion Thread

JerryGauth do-not-reply at jboss.com
Tue Jul 10 13:29:39 EDT 2007


Ignoring HAServiceMBeanSupport/HAServiceMBean for the moment, here's what we're now agreeing to implement, pending other objections.

1)  Remove the following methods from relevant classes.
     ClusterPartitionMBean getClusterPartition()
  |      void setClusterPartition(ClusterPartitionMBean)
  |      void setPartitionName(String)

2)  Add the following methods as replacements.
     HAPartition getHAPartition()
  |      void setHAPartition(HAPartition)

3)  Undeprecate the following "convenience" method.
     String getPartitionName()

I'm not familiar with the use of HAServiceMBeanSupport/HAServiceMBean.  The javadoc and class names suggest that this class is provided to allow clients to extend the implementation and integrate with their own clustered mbeans.  If we modify the mbean/implementation so that clients access the cluster's interface rather than its mbean, does that affect clients who might want access to the mbean itself?





View the original post : http://www.jboss.com/index.html?module=bb&op=viewtopic&p=4062603#4062603

Reply to the post : http://www.jboss.com/index.html?module=bb&op=posting&mode=reply&p=4062603



More information about the jboss-dev-forums mailing list