[keycloak-dev] Change the binding name in ScriptBasedAuthenticator?
thomas.darimont at googlemail.com
Thu May 25 12:35:08 EDT 2017
I haven't had time to look into this yet.
If the authenticationSession is a replacement for Client Session then
I think Option 2 ist fine, as the name alignes with the actual binding.
Am 25.05.2017 6:24 nachm. schrieb "Marek Posolda" <mposolda at redhat.com>:
Hi Thomas and all,
In 3.2 we did some refactoring and authenticators are now using
authenticationSession instead of ClientSession. I see if we should do
something for the ScriptBasedAuthenticator as it;s still using
"clientSession" as binding where it puts authentication session. I can see
1) Keep the binding name "clientSession" for backwards compatibility
2) Change the binding name. Probably to "authenticationSession" ? It would
need to be documented in the migration guide.
My vote is to rather go with 2 as people will likely need to refactor their
scripts anyway. Some method signatures are same for authentication session
like was for client session, but not all. WDYT? Other idea?
More information about the keycloak-dev