On Jul 8, 2011, at 11:27 AM, Christophe Laprun wrote:
On Jul 8, 2011, at 10:35 AM, Julien Viet wrote:
> several remarks at first sight:
>
> 1/ one thing that was discussed on PL (Project Lead) conf call last time was to have
a typed version of the target on the navigation:
>
> Page getPageTarget();
> void setPageTarget(Page page);
> as 97% of the time, the target of a navigation will be a Page (most importantly now
as we have no other possible target).
I'm not part of PL so I wouldn't know that. It's been mentioned but I
didn't see the harm of having something more generic since we know it's probably
going to be extended.
> 2/ I would like to have the Container interface no use the term "child" as
that would make it more reusable (item or element instead)
OK.
> 3/ a site should not be a Container<Page> for several reasons
> - pragmatic : a site can have a large number pages (2000) in some case and the
default method to get children of Container#getChildren() would drain the resource of the
server
This can me mediated by having automatically paged IterableResults.
thing is that ppl will do naturally "for (Page page : site.getPages()) { }
and pages will load all pages out of the box.
what we need is an explicit way like site.getPages(Range.of(0, 10))
> - conceptual : a site is a container of pages and navigations and in the future it
could contain other things (like web resource for instance)
Makes sense.
Cordialement / Best,
Chris
==
Principal Software Engineer / JBoss Enterprise Middleware Red Hat, Inc.
Follow GateIn:
http://blog.gatein.org /
http://twitter.com/gatein
Follow me:
http://metacosm.info/metacosm /
http://twitter.com/metacosm