Wouldn't it be cleaner to have a single method that passes in some context
object that contains details around last sync? Something like:
syncUsers(long lastSync)
Alternatively it can be up to the provider itself to store details around
lastSync and just have a syncUsers method.
On 6 October 2016 at 10:11, Marek Posolda <mposolda(a)redhat.com> wrote:
The "syncChangedUsers" was meant to query the external
storage just for
the users updated since lastSync. The "syncAllUsers" was meant to always
query whole external storage and import/update all users from it into
Keycloak.
I agree that probably most of deployments can live just with the
"syncChangedUsers" . The "syncAllUsers" is probably useful just for
the
case if you really want to enforce syncing all users for some rare
reason (eg. changelog in external storage was somehow broken and doesn't
provide accurate info). I don't know if it's something to consider...
Maybe simplify SPI and go with single method is sufficient.
Marek
On 05/10/16 16:38, Bill Burke wrote:
> Marek in particular...
>
> Why do we have 2 sync methods currently?
>
> syncAllUsers syncChangedUsers
>
> Could we just have one method?
>
> sync(KeycloakSessionFactory sessionFactory, String realmId,
ComponentModel model, DatelastSync);
>
> _______________________________________________
> keycloak-dev mailing list
> keycloak-dev(a)lists.jboss.org
>
https://lists.jboss.org/mailman/listinfo/keycloak-dev
_______________________________________________
keycloak-dev mailing list
keycloak-dev(a)lists.jboss.org
https://lists.jboss.org/mailman/listinfo/keycloak-dev