[JBoss JIRA] (ARQ-1139) Warp: support for @Travelling objects
by Jakub Narloch (JIRA)
[ https://issues.jboss.org/browse/ARQ-1139?page=com.atlassian.jira.plugin.s... ]
Jakub Narloch edited comment on ARQ-1139 at 3/6/13 3:30 AM:
------------------------------------------------------------
I'm not a big star treak fun but how about naming that annotation like:
{code}
@Beam
SomeObject obj;
@Test
public void should() {
Warp.execute(new ClientAction() {
public void action() {
page.doAction();
}
}).verify(new ServerAssertion() {
public void do() {
// beams the obj on the server ;)
obj.op();
}
});
}
{code}
was (Author: jmnarloch):
I'm not a big star treak fun but how about naming that annotation like:
@Beam
SomeObject obj;
@Test
public void should() {
Warp.execute(new ClientAction() {
public void action() {
page.doAction();
}
}).verify(new ServerAssertion() {
public void do() {
// beams the obj on the server ;)
obj.op();
}
});
}
> Warp: support for @Travelling objects
> -------------------------------------
>
> Key: ARQ-1139
> URL: https://issues.jboss.org/browse/ARQ-1139
> Project: Arquillian
> Issue Type: Feature Request
> Security Level: Public(Everyone can see)
> Components: Extension - Warp
> Affects Versions: warp_1.0.0.Alpha1
> Reporter: Lukáš Fryč
> Fix For: warp_1.next
>
>
> {code:java}
> @Travelling
> SomeObject obj;
> @Test
> public void should() {
> Warp.execute(new ClientAction() {
> public void action() {
> page.doAction();
> }
> }).verify(new ServerAssertion() {
> public void do() {
> obj.get(); // detect outside of anonymous class call, replace with callback to client for the value ?
> }
> });
> }
> {code}
> copied from https://gist.github.com/3621257
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira
11 years, 10 months
[JBoss JIRA] (ARQ-1139) Warp: support for @Travelling objects
by Jakub Narloch (JIRA)
[ https://issues.jboss.org/browse/ARQ-1139?page=com.atlassian.jira.plugin.s... ]
Jakub Narloch commented on ARQ-1139:
------------------------------------
I'm not a big star treak fun but how about naming that annotation like:
@Beam
SomeObject obj;
@Test
public void should() {
Warp.execute(new ClientAction() {
public void action() {
page.doAction();
}
}).verify(new ServerAssertion() {
public void do() {
// beams the obj on the server ;)
obj.op();
}
});
}
> Warp: support for @Travelling objects
> -------------------------------------
>
> Key: ARQ-1139
> URL: https://issues.jboss.org/browse/ARQ-1139
> Project: Arquillian
> Issue Type: Feature Request
> Security Level: Public(Everyone can see)
> Components: Extension - Warp
> Affects Versions: warp_1.0.0.Alpha1
> Reporter: Lukáš Fryč
> Fix For: warp_1.next
>
>
> {code:java}
> @Travelling
> SomeObject obj;
> @Test
> public void should() {
> Warp.execute(new ClientAction() {
> public void action() {
> page.doAction();
> }
> }).verify(new ServerAssertion() {
> public void do() {
> obj.get(); // detect outside of anonymous class call, replace with callback to client for the value ?
> }
> });
> }
> {code}
> copied from https://gist.github.com/3621257
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira
11 years, 10 months
[JBoss JIRA] (ARQ-917) Support the use of @Deployment on a static field
by Michal Matloka (JIRA)
[ https://issues.jboss.org/browse/ARQ-917?page=com.atlassian.jira.plugin.sy... ]
Michal Matloka commented on ARQ-917:
------------------------------------
Basing on [~dan.j.allen] ideas from previous comment, maybe in future with Java 8 something like this will be possible:
{code}
@RunWith(Arquillian.class)
@ReadDeploymentFrom(Deployments::myDeploymentMethod)
public class MyTest {
}
{code}
> Support the use of @Deployment on a static field
> ------------------------------------------------
>
> Key: ARQ-917
> URL: https://issues.jboss.org/browse/ARQ-917
> Project: Arquillian
> Issue Type: Enhancement
> Security Level: Public(Everyone can see)
> Components: Base Implementation
> Affects Versions: 1.0.0.Final
> Reporter: Dan Allen
> Priority: Minor
>
> To cut down on verbosity and visual clutter for simple use cases, allow the use of a static field to define a @Deployment. If logic is required to build the deployment, a static block can be used. This also caters well when delegating to a static method.
> See examples in this gist: https://gist.github.com/2640101
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira
11 years, 10 months
[JBoss JIRA] (ARQ-1330) Allow mocking/spying on JSF base classes
by Lukáš Fryč (JIRA)
[ https://issues.jboss.org/browse/ARQ-1330?page=com.atlassian.jira.plugin.s... ]
Lukáš Fryč commented on ARQ-1330:
---------------------------------
The spying extension should be part of Warp JSF extension.
> Allow mocking/spying on JSF base classes
> ----------------------------------------
>
> Key: ARQ-1330
> URL: https://issues.jboss.org/browse/ARQ-1330
> Project: Arquillian
> Issue Type: Feature Request
> Security Level: Public(Everyone can see)
> Reporter: Lukáš Fryč
>
> Spying/mocking classes like FacesContext, Application, ResourceHandler, etc.
> would be great addition to testing capabilities of JSFUnit framework.
> Problem with this concept is that current mock frameworks does support only runtime byte code instrumentation,
> can't provide you implementation class before start of test and thus you can't configure it to JSF runtime.
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira
11 years, 10 months
[JBoss JIRA] (ARQ-1330) Allow mocking/spying on JSF base classes
by Lukáš Fryč (JIRA)
[ https://issues.jboss.org/browse/ARQ-1330?page=com.atlassian.jira.plugin.s... ]
Lukáš Fryč updated ARQ-1330:
----------------------------
Component/s: Extension - Warp
> Allow mocking/spying on JSF base classes
> ----------------------------------------
>
> Key: ARQ-1330
> URL: https://issues.jboss.org/browse/ARQ-1330
> Project: Arquillian
> Issue Type: Feature Request
> Security Level: Public(Everyone can see)
> Components: Extension - Warp
> Reporter: Lukáš Fryč
>
> Spying/mocking classes like FacesContext, Application, ResourceHandler, etc.
> would be great addition to testing capabilities of JSFUnit framework.
> Problem with this concept is that current mock frameworks does support only runtime byte code instrumentation,
> can't provide you implementation class before start of test and thus you can't configure it to JSF runtime.
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira
11 years, 10 months
[JBoss JIRA] (ARQ-1330) Allow mocking/spying on JSF base classes
by Lukáš Fryč (JIRA)
[ https://issues.jboss.org/browse/ARQ-1330?page=com.atlassian.jira.plugin.s... ]
Lukáš Fryč updated ARQ-1330:
----------------------------
Fix Version/s: warp_1.next
> Allow mocking/spying on JSF base classes
> ----------------------------------------
>
> Key: ARQ-1330
> URL: https://issues.jboss.org/browse/ARQ-1330
> Project: Arquillian
> Issue Type: Feature Request
> Security Level: Public(Everyone can see)
> Components: Extension - Warp
> Reporter: Lukáš Fryč
> Fix For: warp_1.next
>
>
> Spying/mocking classes like FacesContext, Application, ResourceHandler, etc.
> would be great addition to testing capabilities of JSFUnit framework.
> Problem with this concept is that current mock frameworks does support only runtime byte code instrumentation,
> can't provide you implementation class before start of test and thus you can't configure it to JSF runtime.
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira
11 years, 10 months
[JBoss JIRA] (ARQ-1330) Allow mocking/spying on JSF base classes
by Lukáš Fryč (JIRA)
[ https://issues.jboss.org/browse/ARQ-1330?page=com.atlassian.jira.plugin.s... ]
Lukáš Fryč moved JSFUNIT-292 to ARQ-1330:
-----------------------------------------
Project: Arquillian (was: JSFUnit)
Key: ARQ-1330 (was: JSFUNIT-292)
Issue Type: Feature Request (was: Task)
Workflow: GIT Pull Request workflow (was: jira)
Assignee: (was: Stan Silvert)
Security: Public
> Allow mocking/spying on JSF base classes
> ----------------------------------------
>
> Key: ARQ-1330
> URL: https://issues.jboss.org/browse/ARQ-1330
> Project: Arquillian
> Issue Type: Feature Request
> Security Level: Public(Everyone can see)
> Reporter: Lukáš Fryč
>
> Spying/mocking classes like FacesContext, Application, ResourceHandler, etc.
> would be great addition to testing capabilities of JSFUnit framework.
> Problem with this concept is that current mock frameworks does support only runtime byte code instrumentation,
> can't provide you implementation class before start of test and thus you can't configure it to JSF runtime.
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira
11 years, 10 months