[JBoss JIRA] (ARQ-591) Create extension for running JavaScript unit tests by Drone
by Karel Piwko (JIRA)
[ https://issues.jboss.org/browse/ARQ-591?page=com.atlassian.jira.plugin.sy... ]
Karel Piwko updated ARQ-591:
----------------------------
Assignee: Tolis Emmanouilidis
> Create extension for running JavaScript unit tests by Drone
> -----------------------------------------------------------
>
> Key: ARQ-591
> URL: https://issues.jboss.org/browse/ARQ-591
> Project: Arquillian
> Issue Type: Feature Request
> Security Level: Public(Everyone can see)
> Components: Extension - Drone
> Reporter: Lukáš Fryč
> Assignee: Tolis Emmanouilidis
>
> This extension can handle several JS unit testing libraries,
> but at initial point, I suggest to go with QUnit [1].
> At first, extension needs to go through available test definitions
> and prepare list of tests to provide it to test runner (JUnit/TestNG).
> At second, test needs to open tested page by Selenium (Drone).
> It would be necessary to run tests by several particular browser brands (HtmlUnit, Firefox, IE, ...).
> QUnit tests are traditionally at once - you open the page and all tests are ran.
> Then runner needs to collect all the results OR it can force QUnit to run only one test at time.
> [1] http://docs.jquery.com/Qunit
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira
11 years, 4 months
[JBoss JIRA] (ARQ-591) Create extension for running JavaScript unit tests by Drone
by Karel Piwko (JIRA)
[ https://issues.jboss.org/browse/ARQ-591?page=com.atlassian.jira.plugin.sy... ]
Karel Piwko commented on ARQ-591:
---------------------------------
This extension is available here https://github.com/arquillian/arquillian-extension-qunit. We would need a separate component instead of making it part of Drone.
> Create extension for running JavaScript unit tests by Drone
> -----------------------------------------------------------
>
> Key: ARQ-591
> URL: https://issues.jboss.org/browse/ARQ-591
> Project: Arquillian
> Issue Type: Feature Request
> Security Level: Public(Everyone can see)
> Components: Extension - Drone
> Reporter: Lukáš Fryč
> Assignee: Tolis Emmanouilidis
>
> This extension can handle several JS unit testing libraries,
> but at initial point, I suggest to go with QUnit [1].
> At first, extension needs to go through available test definitions
> and prepare list of tests to provide it to test runner (JUnit/TestNG).
> At second, test needs to open tested page by Selenium (Drone).
> It would be necessary to run tests by several particular browser brands (HtmlUnit, Firefox, IE, ...).
> QUnit tests are traditionally at once - you open the page and all tests are ran.
> Then runner needs to collect all the results OR it can force QUnit to run only one test at time.
> [1] http://docs.jquery.com/Qunit
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira
11 years, 4 months
[JBoss JIRA] (ARQ-432) Allow tests to intercept initializeBrowser()
by Karel Piwko (JIRA)
[ https://issues.jboss.org/browse/ARQ-432?page=com.atlassian.jira.plugin.sy... ]
Karel Piwko closed ARQ-432.
---------------------------
Assignee: Karel Piwko
Fix Version/s: drone_1.2.0.Beta1
Resolution: Partially Completed
Marking this issue as partially completed. While Drone still does not allow users to dynamically configure configuration per test, it already provides all the extension points to make that happen:
1/ Method parameter injection allows to inject different Drone per test
2/ SPI allow to intercept browser configuration before it is created, thus change it dynamically.
> Allow tests to intercept initializeBrowser()
> --------------------------------------------
>
> Key: ARQ-432
> URL: https://issues.jboss.org/browse/ARQ-432
> Project: Arquillian
> Issue Type: Feature Request
> Security Level: Public(Everyone can see)
> Components: Extension - Drone
> Affects Versions: 1.0.0.Alpha5
> Reporter: Karel Piwko
> Assignee: Karel Piwko
> Fix For: drone_1.2.0.Beta1
>
>
> It might be useful to let user inject custom code in between initializeParameters() and initializeBrowser() methods. This helps to modify test behaviour without direct need to recopy whole AbstractAjocadoTest.
> Usage: lever Selenium browser privileges etc.
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira
11 years, 4 months
[JBoss JIRA] (ARQGRA-328) Support @Drone enricher on Graphene page objects/fragments
by Karel Piwko (JIRA)
[ https://issues.jboss.org/browse/ARQGRA-328?page=com.atlassian.jira.plugin... ]
Karel Piwko moved ARQ-1180 to ARQGRA-328:
-----------------------------------------
Project: Arquillian Graphene (was: Arquillian)
Key: ARQGRA-328 (was: ARQ-1180)
Affects Version/s: 2.0.0.Alpha4
(was: drone_1.1.0.Final)
Component/s: core
(was: Extension - Drone)
Security: (was: Public)
Fix Version/s: (was: drone_1.2.0.next)
> Support @Drone enricher on Graphene page objects/fragments
> ----------------------------------------------------------
>
> Key: ARQGRA-328
> URL: https://issues.jboss.org/browse/ARQGRA-328
> Project: Arquillian Graphene
> Issue Type: Feature Request
> Components: core
> Affects Versions: 2.0.0.Alpha4
> Reporter: Lukáš Fryč
>
> Drone's {{TestEnricher}} fails to work in page fragments.
> If I remember correctly, Drone tries to access or initialize context incorrectly (more information have Aslak).
> This issue is related to ARQGRA-191.
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira
11 years, 4 months
[JBoss JIRA] (ARQ-1180) Support @Drone enricher on Graphene page objects/fragments
by Karel Piwko (JIRA)
[ https://issues.jboss.org/browse/ARQ-1180?page=com.atlassian.jira.plugin.s... ]
Karel Piwko commented on ARQ-1180:
----------------------------------
DroneContext is not empty anymore since 1.2.0.Alpha3. Graphene is now responsible for creating Drone object - more precisely, sending events to let Drone do the work. Moving to Graphene project.
> Support @Drone enricher on Graphene page objects/fragments
> ----------------------------------------------------------
>
> Key: ARQ-1180
> URL: https://issues.jboss.org/browse/ARQ-1180
> Project: Arquillian
> Issue Type: Feature Request
> Security Level: Public(Everyone can see)
> Components: Extension - Drone
> Affects Versions: drone_1.1.0.Final
> Reporter: Lukáš Fryč
> Fix For: drone_1.2.0.next
>
>
> Drone's {{TestEnricher}} fails to work in page fragments.
> If I remember correctly, Drone tries to access or initialize context incorrectly (more information have Aslak).
> This issue is related to ARQGRA-191.
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira
11 years, 4 months
[JBoss JIRA] (ARQ-1209) Abbreviate WebDriver configuration property browserCapabilities as browser
by Karel Piwko (JIRA)
[ https://issues.jboss.org/browse/ARQ-1209?page=com.atlassian.jira.plugin.s... ]
Karel Piwko commented on ARQ-1209:
----------------------------------
browserCapabilities is now legacy value, it is deprecated and automatically mapped to "browser". If both properties are defined at the same time, the action is undefined, as it precedence depends on JDK internals.
> Abbreviate WebDriver configuration property browserCapabilities as browser
> --------------------------------------------------------------------------
>
> Key: ARQ-1209
> URL: https://issues.jboss.org/browse/ARQ-1209
> Project: Arquillian
> Issue Type: Enhancement
> Security Level: Public(Everyone can see)
> Components: Extension - Drone
> Affects Versions: drone_1.1.0.Final
> Reporter: Dan Allen
> Assignee: Karel Piwko
> Labels: starter
> Fix For: drone_1.2.0.Beta1
>
>
> Story:
> *In order to* save typing and make the WebDriver configuration more readable
> *As a* tester
> *I want to* be able to configure the browser using the property name "browser" instead of "browserCapabilities"
> Scenarios:
> *Given* I want to use the FirefoxDriver when running my Drone WebDriver tests
> *When* I set the browser (e.g., firefox) in the WebDriver configuration property named "browser"
> *Then* Drone should interpret the value of that property as the browserCapabilities
> ; *And* Drone should select and initialize the FirefoxDriver
> ; *And* Drone should inject the FirefoxDriver into the @Drone injection point in the test
> *Given* I want to use the FirefoxDriver when running my Drone WebDriver tests
> : *And* I have an existing Drone WebDriver configuration
> *When* I set the browser (e.g., firefox) in the WebDriver configuration property named "browserCapabilities"
> *Then* Drone should interpret the value of that property as the browserCapabilities
> ; *And* Drone should select and initialize the FirefoxDriver
> ; *And* Drone should inject the FirefoxDriver into the @Drone injection point in the test
> Rationale:
> While browserCapabilities is the official name for specifying the browser by its coordinates name, version and platform, we need not expose this formality to our users. We can honor both names for this property, perhaps throwing an exception if both are present. Once we sort that out, we should propose another scenario to cover it.
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira
11 years, 4 months