]
Karel Piwko updated ARQ-1209:
-----------------------------
Fix Version/s: drone_1.2.0.Alpha3
(was: drone_1.2.0.next)
Abbreviate WebDriver configuration property browserCapabilities as
browser
--------------------------------------------------------------------------
Key: ARQ-1209
URL:
https://issues.jboss.org/browse/ARQ-1209
Project: Arquillian
Issue Type: Enhancement
Security Level: Public(Everyone can see)
Components: Extension - Drone
Affects Versions: drone_1.1.0.Final
Reporter: Dan Allen
Labels: starter
Fix For: drone_1.2.0.Alpha3
Story:
*In order to* save typing and make the WebDriver configuration more readable
*As a* tester
*I want to* be able to configure the browser using the property name "browser"
instead of "browserCapabilities"
Scenarios:
*Given* I want to use the FirefoxDriver when running my Drone WebDriver tests
*When* I set the browser (e.g., firefox) in the WebDriver configuration property named
"browser"
*Then* Drone should interpret the value of that property as the browserCapabilities
; *And* Drone should select and initialize the FirefoxDriver
; *And* Drone should inject the FirefoxDriver into the @Drone injection point in the
test
*Given* I want to use the FirefoxDriver when running my Drone WebDriver tests
: *And* I have an existing Drone WebDriver configuration
*When* I set the browser (e.g., firefox) in the WebDriver configuration property named
"browserCapabilities"
*Then* Drone should interpret the value of that property as the browserCapabilities
; *And* Drone should select and initialize the FirefoxDriver
; *And* Drone should inject the FirefoxDriver into the @Drone injection point in the
test
Rationale:
While browserCapabilities is the official name for specifying the browser by its
coordinates name, version and platform, we need not expose this formality to our users. We
can honor both names for this property, perhaps throwing an exception if both are present.
Once we sort that out, we should propose another scenario to cover it.
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: