[
https://issues.jboss.org/browse/ARQ-1139?page=com.atlassian.jira.plugin.s...
]
Jakub Narloch edited comment on ARQ-1139 at 3/6/13 3:30 AM:
------------------------------------------------------------
I'm not a big star treak fun but how about naming that annotation like:
{code}
@Beam
SomeObject obj;
@Test
public void should() {
Warp.execute(new ClientAction() {
public void action() {
page.doAction();
}
}).verify(new ServerAssertion() {
public void do() {
// beams the obj on the server ;)
obj.op();
}
});
}
{code}
was (Author: jmnarloch):
I'm not a big star treak fun but how about naming that annotation like:
@Beam
SomeObject obj;
@Test
public void should() {
Warp.execute(new ClientAction() {
public void action() {
page.doAction();
}
}).verify(new ServerAssertion() {
public void do() {
// beams the obj on the server ;)
obj.op();
}
});
}
Warp: support for @Travelling objects
-------------------------------------
Key: ARQ-1139
URL:
https://issues.jboss.org/browse/ARQ-1139
Project: Arquillian
Issue Type: Feature Request
Security Level: Public(Everyone can see)
Components: Extension - Warp
Affects Versions: warp_1.0.0.Alpha1
Reporter: Lukáš Fryč
Fix For: warp_1.next
{code:java}
@Travelling
SomeObject obj;
@Test
public void should() {
Warp.execute(new ClientAction() {
public void action() {
page.doAction();
}
}).verify(new ServerAssertion() {
public void do() {
obj.get(); // detect outside of anonymous class call, replace with callback to
client for the value ?
}
});
}
{code}
copied from
https://gist.github.com/3621257
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see:
http://www.atlassian.com/software/jira