[
https://jira.jboss.org/browse/ARQ-170?page=com.atlassian.jira.plugin.syst...
]
Dan Allen commented on ARQ-170:
-------------------------------
The start method of the container implementation should also be changed as follows:
// embedded glassfish automatically binds the first port created to http
// the documentation, however, is very fuzzy
server.createPort(containerConfig.getHttpPort());
Rename configuration property for Embedded GlassFish HTTP port
--------------------------------------------------------------
Key: ARQ-170
URL:
https://jira.jboss.org/browse/ARQ-170
Project: Arquillian
Issue Type: Bug
Components: GlassFish Containers
Affects Versions: 1.0.0.Alpha2
Reporter: Dan Allen
The configuration property for the Embedded GlassFish HTTP port is currently bindPort.
However, this is an incorrect name. What this value is actually configuring is the port
on which the http-listener-1 runs (the HTTP port). In fact, it's the only port that
can be configured in Embedded GlassFish. Therefore, the property should be renamed to
httpPort to reflect the proper purpose.
change property bindPort to httpPort in GlassFishConfiguration
--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
https://jira.jboss.org/secure/Administrators.jspa
-
For more information on JIRA, see:
http://www.atlassian.com/software/jira