. Will try to
sort it before the release.
On 17/10/16 13:20, Marek Posolda wrote:
+1 for "options"
On 17/10/16 13:03, Stian Thorgersen wrote:
> +1 Maybe call it options? instead of availableValues.
> On 17 October 2016 at 09:48, Marek Posolda <mposolda(a)redhat.com
> <mailto:email@example.com>> wrote:
> There is one strange thing for ProviderConfigProperties, which
> uses type
> LIST. For those, the "defaultValue" field doesn't really use
> defaultValue of particular field, but instead it contains list of
> available values to be selected in combobox for particular config
> IMO this is not good because of:
> * Field "defaultValue" is used for something, which is not really
> defaultValue. It's a bit confusing IMO. Note once we're adding
> UserStorage SPIs, then customers may need to add their own
> properties of
> type "List" . So this is not just Keycloak implementation detail, but
> it's exposed externally.
> * It's not easily possible to set the actual defaultValue for list
> because field "defaultValue" is occupied by the list of available
> How about adding new field like "availableValues" to
> ProviderConfigProperty and refactor existing impls to use this one
> keycloak-dev mailing list
> keycloak-dev(a)lists.jboss.org <mailto:firstname.lastname@example.org>
keycloak-dev mailing list