[
http://opensource.atlassian.com/projects/hibernate/browse/HSEARCH-414?pag...
]
Sanne Grinovero commented on HSEARCH-414:
-----------------------------------------
On first impact, I got a bit confused about "term().on(" ; you mean a TermQuery
right?
So wouldn't
monthQb.term().on( "mythology_ngram" ).matches( "snobored"
).createQuery();
be more readable as
monthQb.termQuery( "mythology_ngram" ).matches( "snobored"
).create();
sorry I have the vague idea we talked about something like that, but forgot the reasons if
any;
term().on() doesn't seem bad either, just a matter of taste :)
I'll give it a try and get you some better feedback.
Tests are very readable, are you going to add some using booleanQuery to show a composite
query?
I've been looking into the new Lucene's features to create efficient RangeQuery on
number/dates, that definitely needs some helpers - just a thought for future.
Is it picking the right analyzer automatically (from field name) ?
Add support for a Lucene query builder using a fluent API
---------------------------------------------------------
Key: HSEARCH-414
URL:
http://opensource.atlassian.com/projects/hibernate/browse/HSEARCH-414
Project: Hibernate Search
Issue Type: New Feature
Components: query
Reporter: Emmanuel Bernard
Fix For: 3.2.0.Beta3
--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
http://opensource.atlassian.com/projects/hibernate/secure/Administrators....
-
For more information on JIRA, see:
http://www.atlassian.com/software/jira