[
http://opensource.atlassian.com/projects/hibernate/browse/HSEARCH-711?pag...
]
Hardy Ferentschik updated HSEARCH-711:
--------------------------------------
Description:
We're having Enum values labeled NO,TOKENIZED,UN_TOKENIZED,NO_NORMS,..
while Lucene changed these names to more suited "analyzed",
"not_analyzed", etc.
Also I think it would be great to use an array of parameters instead of an enum listing
all options, or maybe split the option in two:
{code}
@Field({ANALYZE,NO_NORMS})
{code}
or
{code}
@Field(analyze=YES,norms=No)
{code}
We should at least deprecate current names and use the more appropriate terms.
was:
We're having Enum values labeled NO,TOKENIZED,UN_TOKENIZED,NO_NORMS,..
while Lucene changed these names to more suited "analyzed",
"not_analyzed", etc.
Also I think it would be great to use an array of parameters instead of an enum listing
all options, or maybe split the option in two:
@Field({ANALYZE,NO_NORMS})
or
@Field(analyze=YES,norms=No)
We should at least deprecate current names and use the more appropriate terms.
Review of org.hibernate.search.annotations.Index API (token names,
parameter composition)
-----------------------------------------------------------------------------------------
Key: HSEARCH-711
URL:
http://opensource.atlassian.com/projects/hibernate/browse/HSEARCH-711
Project: Hibernate Search
Issue Type: Deprecation
Reporter: Sanne Grinovero
Fix For: 4.0.0.Beta1
We're having Enum values labeled NO,TOKENIZED,UN_TOKENIZED,NO_NORMS,..
while Lucene changed these names to more suited "analyzed",
"not_analyzed", etc.
Also I think it would be great to use an array of parameters instead of an enum listing
all options, or maybe split the option in two:
{code}
@Field({ANALYZE,NO_NORMS})
{code}
or
{code}
@Field(analyze=YES,norms=No)
{code}
We should at least deprecate current names and use the more appropriate terms.
--
This message is automatically generated by JIRA.
For more information on JIRA, see:
http://www.atlassian.com/software/jira