[
http://opensource.atlassian.com/projects/hibernate/browse/HHH-6229?page=c...
]
Steve Ebersole commented on HHH-6229:
-------------------------------------
Some of this is covered in HHH-6281 in terms of breaking this up into what I thought was
more logical pieces ({{BindingContext}} and {{MappingDefaults}}).
The name {{MappingDefaults}} is perfectly fine I think. That is what they are. Default
values for missing values in the mappings. Not stoked about the use of the term
"default" in the method names. Also, I absolutely dislike the meta-attributes
stuff still being on this interface; but was uncertain at that moment of a better way.
Determine data that should go into metamodel.binding.MappingDefaults
--------------------------------------------------------------------
Key: HHH-6229
URL:
http://opensource.atlassian.com/projects/hibernate/browse/HHH-6229
Project: Hibernate Core
Issue Type: Task
Components: core
Reporter: Gail Badner
Assignee: Gail Badner
Fix For: 4.0.0.Beta1
MappingDefaults interface currently has the following methods:
Map<String, MetaAttribute> getMappingMetas();
String getPackageName();
String getDefaultSchemaName();
String getDefaultCatalogName();
String getDefaultIdColumnName();
String getDefaultDescriminatorColumnName();
String getDefaultCascade();
String getDefaultAccess();
boolean isDefaultLazy();
ServiceRegistry getServiceRegistry();
NamingStrategy getNamingStrategy();
Implementations are supposed to return global values, updated with overrides.
Any suggestions on a better name?
--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
http://opensource.atlassian.com/projects/hibernate/secure/Administrators....
-
For more information on JIRA, see:
http://www.atlassian.com/software/jira