[
https://jira.jboss.org/browse/CDI-17?page=com.atlassian.jira.plugin.syste...
]
Dan Allen edited comment on CDI-17 at 10/26/10 3:37 PM:
--------------------------------------------------------
To be honest, I was pretty confused myself whether "receive" or
"notifyObserver" is the correct name for compliance. I'm aware of the major
breakage as I've been slapped by that exception quite a few times.
I like receive better than notifyObserver. So if it can't be notified, then receive is
the next best alternative in my mind. As long as it's not notifyObserver.
was (Author: dan.j.allen):
To be honest, I was pretty confused myself whether "receive" or
"notifyObserver" was the correct name for compliance. I'm aware of the major
breakage as I've been slapped by that exception quite a few times.
I like receive better than notifyObserver. So if it can't be notified, then receive is
the next best alternative in my mind. As long as it's not notifyObserver.
Change name of the @Observes Reception attribute to
"notified"
--------------------------------------------------------------
Key: CDI-17
URL:
https://jira.jboss.org/browse/CDI-17
Project: CDI Specification Issues
Issue Type: Feature Request
Components: Javadoc and API
Affects Versions: 1.0
Reporter: Dan Allen
Priority: Minor
Fix For: 1.1
As of the CDI 1.0 specification, the name of the Reception attribute on @Observes is
"receive". The patch release of the API (SP1) changes the name to
"notifyObserver", so a change is already being considered. Therefore, I'd
like to suggest a better name that would read more fluently. That name is
"notified".
Let us compare the three cases:
1. @Observes(receive = IF_EXISTS)
2. @Observes(notifyObserver = IF_EXISTS)
3. @Observes(notified = IF_EXISTS)
Of the three, notifyObserver breaks the flow of the sentence the most. On the other hand,
notified reads nicely, including with the TransactionPhase attribute included:
@Observes(notified = IF_EXISTS, during = TransactionPhase.AFTER_SUCCESS)
--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
https://jira.jboss.org/secure/Administrators.jspa
-
For more information on JIRA, see:
http://www.atlassian.com/software/jira