[
https://jira.jboss.org/browse/CDI-17?page=com.atlassian.jira.plugin.syste...
]
Stuart Douglas commented on CDI-17:
-----------------------------------
Calling it notifyObserver in the SP1 release was a bug, SP2 fixed this and changed it to
receive.
This broke backwards compatibility in a big way, as many jars compiled against the latest
CDI-API no longer work with weld 1.0 and visa versa, which has been a big problem for
extension developers. I don't think the difference between recieve and notified is
significant enough to be worth breaking backward compatibility for.
Change name of the @Observes Reception attribute to
"notified"
--------------------------------------------------------------
Key: CDI-17
URL:
https://jira.jboss.org/browse/CDI-17
Project: CDI Specification Issues
Issue Type: Feature Request
Components: Javadoc and API
Affects Versions: 1.0
Reporter: Dan Allen
Priority: Minor
Fix For: 1.1
As of the CDI 1.0 specification, the name of the Reception attribute on @Observes is
"receive". The patch release of the API (SP1) changes the name to
"notifyObserver", so a change is already being considered. Therefore, I'd
like to suggest a better name that would read more fluently. That name is
"notified".
Let us compare the three cases:
1. @Observes(receive = IF_EXISTS)
2. @Observes(notifyObserver = IF_EXISTS)
3. @Observes(notified = IF_EXISTS)
Of the three, notifyObserver breaks the flow of the sentence the most. On the other hand,
notified reads nicely, including with the TransactionPhase attribute included:
@Observes(notified = IF_EXISTS, during = TransactionPhase.AFTER_SUCCESS)
--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
https://jira.jboss.org/secure/Administrators.jspa
-
For more information on JIRA, see:
http://www.atlassian.com/software/jira