[
https://issues.jboss.org/browse/ARQGRA-230?page=com.atlassian.jira.plugin...
]
Jan Papousek commented on ARQGRA-230:
-------------------------------------
It's a good idea, but...
The toString() method should somehow describe the current instance and I don't think
it should be {code}waiting for text ('xyz') to be equal to text in element
'id: form:output' but it was 'xy'{code} It doean't make sense without
the context of waiting message. I propose to change your text to:
{code}
waiting for text ('xyz') to be equal to text ('xy') in element 'id:
form:output'
{code}
Override a toString method in BooleanConditionWrapper
-----------------------------------------------------
Key: ARQGRA-230
URL:
https://issues.jboss.org/browse/ARQGRA-230
Project: Arquillian Graphene
Issue Type: Enhancement
Reporter: Jiří Štefek
Assignee: Jan Papousek
Priority: Trivial
Fix For: 2.0.0.Alpha3
It would be great if BooleanConditionWrapper had its own toString() method, so the logs
from selenium could be more readable than:
{code}org.openqa.selenium.TimeoutException: Timed out after 5 seconds waiting for
org.jboss.arquillian.graphene.condition.BooleanConditionWrapper@198de25e{code}
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see:
http://www.atlassian.com/software/jira