[JBoss JIRA] (ISPN-7139) Consistent prefix in property names of Hot Rod client configurations
by Galder Zamarreño (JIRA)
[ https://issues.jboss.org/browse/ISPN-7139?page=com.atlassian.jira.plugin.... ]
Galder Zamarreño updated ISPN-7139:
-----------------------------------
Fix Version/s: 9.4.0.Final
(was: 9.3.0.Final)
> Consistent prefix in property names of Hot Rod client configurations
> --------------------------------------------------------------------
>
> Key: ISPN-7139
> URL: https://issues.jboss.org/browse/ISPN-7139
> Project: Infinispan
> Issue Type: Enhancement
> Components: Configuration, Remote Protocols
> Reporter: Sanne Grinovero
> Fix For: 9.4.0.Final
>
>
> Most Hot Rod configuration properties use the prefix {{infinispan.client.hotrod.}} which makes it easy to recognize them.
> Some properties don't use the prefix though, such as all those related to connection pooling, e.g. {{maxActive}}, {{maxTotal}}, ..
> This makes it hard to read Hot Rod specific configuration properties from alternative sources. In particular we'd like to embed such properties in an Hibernate configuration file (for Hibernate OGM) but the fact that some properties need special handling forces us to keep a list of these to have special care, rather than being able to use a prefix like it is done in most such cases.
> It should be easy to prefix all the properties, and deprecate the names.
--
This message was sent by Atlassian JIRA
(v7.5.0#75005)
6 years, 6 months
[JBoss JIRA] (ISPN-7624) Change CacheLoaderInterceptor to ignore in memory for certain operations when passivation is not enabled
by Galder Zamarreño (JIRA)
[ https://issues.jboss.org/browse/ISPN-7624?page=com.atlassian.jira.plugin.... ]
Galder Zamarreño updated ISPN-7624:
-----------------------------------
Fix Version/s: 9.4.0.Final
(was: 9.3.0.Final)
> Change CacheLoaderInterceptor to ignore in memory for certain operations when passivation is not enabled
> --------------------------------------------------------------------------------------------------------
>
> Key: ISPN-7624
> URL: https://issues.jboss.org/browse/ISPN-7624
> Project: Infinispan
> Issue Type: Bug
> Components: Loaders and Stores
> Reporter: William Burns
> Assignee: William Burns
> Fix For: 9.4.0.Final
>
>
> CacheLoader currently reads all in memory entries and then the store for bulk operations. This can be changed to only load from the store when passivation is not used as it should contain all entries that aren't in memory.
> The only issue is that if Flag.SKIP_CACHE_STORE was used on a write. In this case we could store a boolean in the interceptor so that if this Flag is ever used we always do both. Very few users use this Flag and it should improve performance a bit and entries should be seen more consistently.
--
This message was sent by Atlassian JIRA
(v7.5.0#75005)
6 years, 6 months
[JBoss JIRA] (ISPN-7606) DistributedExecutorMassIndexer.executeInternal should use an existing pool
by Galder Zamarreño (JIRA)
[ https://issues.jboss.org/browse/ISPN-7606?page=com.atlassian.jira.plugin.... ]
Galder Zamarreño updated ISPN-7606:
-----------------------------------
Fix Version/s: 9.4.0.Final
(was: 9.3.0.Final)
> DistributedExecutorMassIndexer.executeInternal should use an existing pool
> --------------------------------------------------------------------------
>
> Key: ISPN-7606
> URL: https://issues.jboss.org/browse/ISPN-7606
> Project: Infinispan
> Issue Type: Bug
> Components: Embedded Querying
> Affects Versions: 9.0.0.CR2
> Reporter: Dan Berindei
> Assignee: Gustavo Fernandes
> Fix For: 9.4.0.Final
>
>
> {{DistributedExecutorMassIndexer.executeInternal}} creates 2 executors:
> 1. {{new DefaultExecutorService(cache)}} implicitly creates a single-threaded executor to run tasks on the local node.
> 2. {{compositeFuture.whenCompleteAsync(consumer, Executors.newSingleThreadExecutor())}} explicitly creates a new single-threaded executor to run the consumer on.
> Neither of these executors are shut down, and rather than complicating the code to stop them properly it would be better to use an existing executor.
--
This message was sent by Atlassian JIRA
(v7.5.0#75005)
6 years, 6 months
[JBoss JIRA] (ISPN-7590) Invocation idempotence
by Galder Zamarreño (JIRA)
[ https://issues.jboss.org/browse/ISPN-7590?page=com.atlassian.jira.plugin.... ]
Galder Zamarreño updated ISPN-7590:
-----------------------------------
Fix Version/s: 9.4.0.Final
(was: 9.3.0.Final)
> Invocation idempotence
> ----------------------
>
> Key: ISPN-7590
> URL: https://issues.jboss.org/browse/ISPN-7590
> Project: Infinispan
> Issue Type: Task
> Components: Core
> Affects Versions: 9.0.0.CR2
> Reporter: Radim Vansa
> Assignee: Radim Vansa
> Labels: consistency
> Fix For: 9.4.0.Final
>
>
> This is an umbrella JIRA to change the way how we deal with retries after topology change.
> Please link any outstanding issues that refer to incorrect return values of command during topology change.
--
This message was sent by Atlassian JIRA
(v7.5.0#75005)
6 years, 6 months