Paul Ferraro created ISPN-7192:
----------------------------------
Summary: Replace RemoteCache.getRemoteCacheManager() with method that returns
RemoteCacheContainer
Key: ISPN-7192
URL:
https://issues.jboss.org/browse/ISPN-7192
Project: Infinispan
Issue Type: Enhancement
Components: Remote Protocols
Affects Versions: 9.0.0.Alpha4
Reporter: Paul Ferraro
org.infinispan.Cache already has a getCacheManager() method that returns an interface.
Let's generalize this to BasicCache such that RemoteCache has an analogous method that
returns RemoteCacheContainer.
However, the naming is really inconsistent. Should we name these:
BasicCache.getCacheManager()::BasicCacheContainer
Cache.getCacheManager()::EmbeddedCacheManager
RemoteCache.getCacheManager()::RemoteCacheContainer
or:
BasicCache.getCacheContainer()::BasicCacheContainer
Cache.getCacheContainer()::EmbeddedCacheManager
RemoteCache.getCacheContainer()::RemoteCacheContainer
It would be great if we could standardize the "cache manager" vs "cache
container" naming convention. Given that "cache container" seems more
prevalent in the API, I suggest going with that convention. This is complicated by the
fact that org.infinispan.manager.CacheContainer already exists, but is not particularly
useful.
1. Creating a new org.infinispan.CacheContainer (in the same package as Cache, maybe
extending org.infinispan.manager.CacheContainer) with some API refinements. e.g.
getName()::String, getDefaultCacheName()::String, remove cruft, etc.
2. Deprecate EmbeddedCacheManager and have it extend this new CacheContainer interface and
deprecate it.
That way we can have:
BasicCache.getCacheContainer()::BasicCacheContainer
Cache.getCacheContainer()::org.infinispan.CacheContainer
RemoteCache.getCacheContainer()::RemoteCacheContainer
--
This message was sent by Atlassian JIRA
(v7.2.3#72005)