HOSA has its own Prometheus endpoint that emits its own metrics. Right now, we just have
one custom agent metric but we plan to add more. Before I get too far, I'm trying to
figure out a good prefix to use for metric names.
I was looking over the Prometheus naming conventions for metric names here:
https://prometheus.io/docs/practices/naming/
In addition, I found additional naming conventions listed in the Prom Go client comments
here:
https://github.com/prometheus/client_golang/blob/master/prometheus/metric...
Right now the one custom agent metric is called:
hawkular_openshift_agent_metric_data_points_collected_total
I think it's too long :) And the "subsystem" is two words (openshift_agent)
when the Go comment says (and all other prometheus metrics I've seen) use one word
with no underscore.
I think starting it with "hawkular_" is good because looking at the metric you
immediately know it is from a Hawkular component. But I don't know what the subsystem
should be.
I was thinking:
hawkular_openshiftagent_<metric-name>
That is a one-word subsystem "openshiftagent" but its still too long IMO.
Maybe:
hawkular_agent_<metric-name>
But then, if our other agents emit their own metrics in the future, this will be confusing
(think vert.x agent, fuse agent, whatever).
How about use the HOSA abbreviation?
hawkular_hosa_<metric-name>
That seems smaller and is more specific to the OpenShift Agent. But will "HOSA"
make sense to people?
Thoughts? Suggestions?