[
http://opensource.atlassian.com/projects/hibernate/browse/HHH-6229?page=c...
]
Steve Ebersole updated HHH-6229:
--------------------------------
Summary: Clean up MappingDefaults (was: Determine data that should go into
metamodel.binding.MappingDefaults)
Clean up MappingDefaults
------------------------
Key: HHH-6229
URL:
http://opensource.atlassian.com/projects/hibernate/browse/HHH-6229
Project: Hibernate Core
Issue Type: Task
Components: core
Reporter: Gail Badner
Assignee: Steve Ebersole
Fix For: 4.0.0.Beta1
MappingDefaults interface currently has the following methods:
Map<String, MetaAttribute> getMappingMetas();
String getPackageName();
String getDefaultSchemaName();
String getDefaultCatalogName();
String getDefaultIdColumnName();
String getDefaultDescriminatorColumnName();
String getDefaultCascade();
String getDefaultAccess();
boolean isDefaultLazy();
ServiceRegistry getServiceRegistry();
NamingStrategy getNamingStrategy();
Implementations are supposed to return global values, updated with overrides.
Any suggestions on a better name?
--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
http://opensource.atlassian.com/projects/hibernate/secure/Administrators....
-
For more information on JIRA, see:
http://www.atlassian.com/software/jira