[
https://issues.jboss.org/browse/SEAMFORGE-79?page=com.atlassian.jira.plug...
]
Pablo Martinez updated SEAMFORGE-79:
------------------------------------
Description:
When using the new-field command, the getters and setters should be separated from the
fields, to make the java class more readable after using seamforge.
An idea is to separate every java class in 4 parts: Field block, Constructor block,
Getter/Setter block and Method block, using some arbitrary sintax (for easy parsing
maybe?), for example something like:
@Entity
public class User {
/* [FIELDS] */
private int id;
private String username;
private String password;
/* [CONSTRUCTORS] */
public User() {
}
public User(String username, String password) {
}
/* [GETTERS/SETTERS] */
public String getUsername() {
return this.username;
}
public void setUsername(final String username) {
this.username = username;
}
//etc...
/* [METHODS] */
public void doSomething() { }
public boolean equals(User other) { return false; }
//etc...
}
was:
When using the new-field command, the getters and setters should be separated from the
fields, to make the java class more readable after using seamforge.
An idea is to separate every java class in 4 parts: Field block, Constructor block,
Getter/Setter block and Method block, using some arbitrary sintax (for easy parsing
maybe?), for example something like:
@Entity
public class User {
/* [FIELDS] */
private int id;
private String username;
private String password;
/* [CONSTRUCTORS] */
public User() {
}
public User(String username, String password) {
}
/* [GETTERS/SETTERS] */
public String getUsername() {
return this.username;
}
public void setUsername(final String username) {
this.username = username;
}
//etc...
}
When using the new-field command, the getters and setters should be
separated from the field to make it more readable.
----------------------------------------------------------------------------------------------------------------------
Key: SEAMFORGE-79
URL:
https://issues.jboss.org/browse/SEAMFORGE-79
Project: Seam Forge
Issue Type: Feature Request
Components: Brainstorming
Affects Versions: 1.0.0.Alpha1, 1.0.0.Alpha2, 1.0.0.Alpha3
Reporter: Pablo Martinez
Priority: Optional
When using the new-field command, the getters and setters should be separated from the
fields, to make the java class more readable after using seamforge.
An idea is to separate every java class in 4 parts: Field block, Constructor block,
Getter/Setter block and Method block, using some arbitrary sintax (for easy parsing
maybe?), for example something like:
@Entity
public class User {
/* [FIELDS] */
private int id;
private String username;
private String password;
/* [CONSTRUCTORS] */
public User() {
}
public User(String username, String password) {
}
/* [GETTERS/SETTERS] */
public String getUsername() {
return this.username;
}
public void setUsername(final String username) {
this.username = username;
}
//etc...
/* [METHODS] */
public void doSomething() { }
public boolean equals(User other) { return false; }
//etc...
}
--
This message is automatically generated by JIRA.
For more information on JIRA, see:
http://www.atlassian.com/software/jira