[JBoss JIRA] (CDI-621) removeAll() method is ambiguous in multiple configurators.
by Matej Novotny (JIRA)
[ https://issues.jboss.org/browse/CDI-621?page=com.atlassian.jira.plugin.sy... ]
Matej Novotny commented on CDI-621:
-----------------------------------
bq. Maybe at a later point you can change other things...
At that later point, should it ever come to that, you need merely mark {{removeAll}} as deprecated and delegate its' call to newly created {{removeAllAnnotations}} method.
But if you really feel like having it right away makes things easier, I am not against it. From my POV its not such a big deal.
> removeAll() method is ambiguous in multiple configurators.
> ----------------------------------------------------------
>
> Key: CDI-621
> URL: https://issues.jboss.org/browse/CDI-621
> Project: CDI Specification Issues
> Issue Type: Clarification
> Reporter: John Ament
>
> The method removeAll is ambiguous. This problem doesn't exist for remove(Annotation) or remove(Class) since they're type safe. The removeAll method presupposes that annotations are the only thing to configure.
--
This message was sent by Atlassian JIRA
(v6.4.11#64026)
8 years, 1 month
[JBoss JIRA] (CDI-621) removeAll() method is ambiguous in multiple configurators.
by Martin Kouba (JIRA)
[ https://issues.jboss.org/browse/CDI-621?page=com.atlassian.jira.plugin.sy... ]
Martin Kouba commented on CDI-621:
----------------------------------
Feel free to rename it. But from my POV {{removeAllAnnotations()}} and similar would be a bad name because a user might expect to be able to remove other things than annotations and that's what {{AnnotatedTypeConfigurator}} is not allowed to do or intended for. So I still believe it would be more meaningful to emphasize that {{AnnotatedTypeConfigurator}} works only with annotations and that's it.
> removeAll() method is ambiguous in multiple configurators.
> ----------------------------------------------------------
>
> Key: CDI-621
> URL: https://issues.jboss.org/browse/CDI-621
> Project: CDI Specification Issues
> Issue Type: Clarification
> Reporter: John Ament
>
> The method removeAll is ambiguous. This problem doesn't exist for remove(Annotation) or remove(Class) since they're type safe. The removeAll method presupposes that annotations are the only thing to configure.
--
This message was sent by Atlassian JIRA
(v6.4.11#64026)
8 years, 1 month
[JBoss JIRA] (CDI-621) removeAll() method is ambiguous in multiple configurators.
by Romain Manni-Bucau (JIRA)
[ https://issues.jboss.org/browse/CDI-621?page=com.atlassian.jira.plugin.sy... ]
Romain Manni-Bucau commented on CDI-621:
----------------------------------------
[~mkouba] I tend to join John on that, if you need to check the javadoc to understand what a method does the method is likely badly named. Also the renaming is quite trivial and would benefit user experience in IDE (you dont need to go on all methods to read the javadoc to know which one you need to use)
> removeAll() method is ambiguous in multiple configurators.
> ----------------------------------------------------------
>
> Key: CDI-621
> URL: https://issues.jboss.org/browse/CDI-621
> Project: CDI Specification Issues
> Issue Type: Clarification
> Reporter: John Ament
>
> The method removeAll is ambiguous. This problem doesn't exist for remove(Annotation) or remove(Class) since they're type safe. The removeAll method presupposes that annotations are the only thing to configure.
--
This message was sent by Atlassian JIRA
(v6.4.11#64026)
8 years, 1 month
[JBoss JIRA] (CDI-621) removeAll() method is ambiguous in multiple configurators.
by Martin Kouba (JIRA)
[ https://issues.jboss.org/browse/CDI-621?page=com.atlassian.jira.plugin.sy... ]
Martin Kouba commented on CDI-621:
----------------------------------
Yes, only annotations of the type and its members. The sets of members are immutable (mentioned in javadoc) and the same applies to streams. If it's not clear we should mention this in the class javadoc and improve the "AnnotatedTypeConfigurator SPI" section.
> removeAll() method is ambiguous in multiple configurators.
> ----------------------------------------------------------
>
> Key: CDI-621
> URL: https://issues.jboss.org/browse/CDI-621
> Project: CDI Specification Issues
> Issue Type: Clarification
> Reporter: John Ament
>
> The method removeAll is ambiguous. This problem doesn't exist for remove(Annotation) or remove(Class) since they're type safe. The removeAll method presupposes that annotations are the only thing to configure.
--
This message was sent by Atlassian JIRA
(v6.4.11#64026)
8 years, 1 month
[JBoss JIRA] (CDI-621) AnnotatedTypeConfigurator.removeAll() method can lead to ambiguities
by Martin Kouba (JIRA)
[ https://issues.jboss.org/browse/CDI-621?page=com.atlassian.jira.plugin.sy... ]
Martin Kouba edited comment on CDI-621 at 8/31/16 6:46 AM:
-----------------------------------------------------------
Well, the point is the {{AnnotatedTypeConfigurator}} and friends ({{AnnotatedMethodConfigurator}}, etc.) can ONLY be used to modify/configure annotations. So it's implicit. Also the javadoc is clear.
was (Author: mkouba):
Well, the point is the {{AnnotatedTypeConfigurator}} and firends ({{AnnotatedMethodConfigurator}}, ...) can ONLY be used to modify/configure annotations. So it's implicit. Also the javadoc is clear.
> AnnotatedTypeConfigurator.removeAll() method can lead to ambiguities
> --------------------------------------------------------------------
>
> Key: CDI-621
> URL: https://issues.jboss.org/browse/CDI-621
> Project: CDI Specification Issues
> Issue Type: Clarification
> Reporter: John Ament
>
> The method removeAll is ambiguous. This problem doesn't exist for remove(Annotation) or remove(Class) since they're type safe. The removeAll method presupposes that annotations are the only thing to configure.
--
This message was sent by Atlassian JIRA
(v6.4.11#64026)
8 years, 1 month
[JBoss JIRA] (CDI-621) AnnotatedTypeConfigurator.removeAll() method can lead to ambiguities
by Martin Kouba (JIRA)
[ https://issues.jboss.org/browse/CDI-621?page=com.atlassian.jira.plugin.sy... ]
Martin Kouba commented on CDI-621:
----------------------------------
Well, the point is the {{AnnotatedTypeConfigurator}} and firends ({{AnnotatedMethodConfigurator}}, ...) can ONLY be used to modify/configure annotations. So it's implicit. Also the javadoc is clear.
> AnnotatedTypeConfigurator.removeAll() method can lead to ambiguities
> --------------------------------------------------------------------
>
> Key: CDI-621
> URL: https://issues.jboss.org/browse/CDI-621
> Project: CDI Specification Issues
> Issue Type: Clarification
> Reporter: John Ament
>
> The method removeAll is ambiguous. This problem doesn't exist for remove(Annotation) or remove(Class) since they're type safe. The removeAll method presupposes that annotations are the only thing to configure.
--
This message was sent by Atlassian JIRA
(v6.4.11#64026)
8 years, 1 month