Hi all,
I'm a bit particular on wording because I think that the right word makes
things easier for the new comer. I'm implementing a new UI command to add
an injection point to a class. So, the name of the command would be
cdi-add-injection-point. But then I started to have a look at the other xxx-
*add*-yyy commands :
addon-add-dependency
project-add-dependencies
project-add-managed-dependencies
project-add-repository
java-add-annotation
constraint-add
They all add something, into something already existing. If we take this
definition for granted, shouldn't the following commands be renamed *add*
instead of *new* :
jpa-new-named-query
cdi-new-conversation
java-new-enum-const
java-new-field
java-new-method
jpa-new-field
--
Antonio Goncalves
Software architect and Java Champion
Web site <
http://www.antoniogoncalves.org/> | Twitter
<
http://twitter.com/agoncal> | LinkedIn <
http://www.linkedin.com/in/agoncal>
| Paris JUG <
http://www.parisjug.org/> | Devoxx France
<
http://www.devoxx.fr/>