[JBoss JIRA] (JBIDE-26582) Add support for Quarkus based applications
by Jeff MAURY (Jira)
[ https://issues.jboss.org/browse/JBIDE-26582?page=com.atlassian.jira.plugi... ]
Jeff MAURY updated JBIDE-26582:
-------------------------------
Fix Version/s: 4.13.0.Final
(was: 4.13.0.AM1)
> Add support for Quarkus based applications
> ------------------------------------------
>
> Key: JBIDE-26582
> URL: https://issues.jboss.org/browse/JBIDE-26582
> Project: Tools (JBoss Tools)
> Issue Type: Bug
> Components: openshift
> Affects Versions: 4.11.0.Final
> Reporter: Jeff MAURY
> Priority: Major
> Fix For: 4.13.0.Final
>
>
> We should support JBoss Tools based inner loop for Quarkus based applications.
> In the first time support only OpenJDK based deployments as I'm not sure native image based deployments can support inner loop.
> That would also probably means an update of the openJDK base image
--
This message was sent by Atlassian Jira
(v7.13.8#713008)
5 years, 1 month
[JBoss JIRA] (JBIDE-26548) Nullpointer when renaming inner class java variables - JSFRenameFieldParticipant
by Jeff MAURY (Jira)
[ https://issues.jboss.org/browse/JBIDE-26548?page=com.atlassian.jira.plugi... ]
Jeff MAURY updated JBIDE-26548:
-------------------------------
Fix Version/s: 4.13.0.Final
(was: 4.13.0.AM1)
> Nullpointer when renaming inner class java variables - JSFRenameFieldParticipant
> --------------------------------------------------------------------------------
>
> Key: JBIDE-26548
> URL: https://issues.jboss.org/browse/JBIDE-26548
> Project: Tools (JBoss Tools)
> Issue Type: Bug
> Components: jsf
> Affects Versions: 4.10.0.AM1
> Environment: Linux with Eclipse 2018-12
> Reporter: Thomas Zauner
> Assignee: Jeff MAURY
> Priority: Major
> Fix For: 4.13.0.Final
>
>
> Renaming of inner class java variables leads to an Nullpointer in JSFRenameFieldParticipant. The second rename is working, since the JSFRenameFieldParticipant is removed due to the exception.
> {noformat}
> !ENTRY org.eclipse.ltk.core.refactoring 4 10009 2019-02-07 08:02:57.183
> !MESSAGE Participant 'org.jboss.tools.jsf.model.handlers.bean.JSFRenameFieldParticipant' removed due to the following exception
> !STACK 0
> java.lang.NullPointerException
> at org.jboss.tools.jsf.model.pv.JSFProjectsTree.getProjectsRoot(JSFProjectsTree.java:45)
> at org.jboss.tools.jsf.model.handlers.bean.JSFRenameFieldHelper.getBeanList(JSFRenameFieldHelper.java:48)
> at org.jboss.tools.jsf.model.handlers.bean.JSFRenameFieldParticipant.createChange(JSFRenameFieldParticipant.java:68)
> at org.eclipse.ltk.core.refactoring.participants.ProcessorBasedRefactoring.createChange(ProcessorBasedRefactoring.java:309)
> at org.eclipse.jdt.internal.ui.refactoring.RefactoringExecutionHelper$Operation.run(RefactoringExecutionHelper.java:102)
> at org.eclipse.jdt.internal.core.BatchOperation.executeOperation(BatchOperation.java:41)
> at org.eclipse.jdt.internal.core.JavaModelOperation.run(JavaModelOperation.java:736)
> at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:2295)
> at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:2322)
> at org.eclipse.jdt.core.JavaCore.run(JavaCore.java:5810)
> at org.eclipse.jdt.internal.ui.actions.WorkbenchRunnableAdapter.run(WorkbenchRunnableAdapter.java:108)
> at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:122)
> {noformat}
> {code:java}
> public class JavaClass {
> private boolean first; // rename will work
> public class InnerClass {
> private boolean second; // rename leads to NPE
> }
> }
> {code}
--
This message was sent by Atlassian Jira
(v7.13.8#713008)
5 years, 1 month
[JBoss JIRA] (JBIDE-26751) Content Assist item in the Edit menu is missing when cursor is placed between the angle brackets ('<' and '>') in the beans.xml (CDI project) file
by Jeff MAURY (Jira)
[ https://issues.jboss.org/browse/JBIDE-26751?page=com.atlassian.jira.plugi... ]
Jeff MAURY updated JBIDE-26751:
-------------------------------
Fix Version/s: 4.13.0.Final
(was: 4.13.0.AM1)
> Content Assist item in the Edit menu is missing when cursor is placed between the angle brackets ('<' and '>') in the beans.xml (CDI project) file
> --------------------------------------------------------------------------------------------------------------------------------------------------
>
> Key: JBIDE-26751
> URL: https://issues.jboss.org/browse/JBIDE-26751
> Project: Tools (JBoss Tools)
> Issue Type: Bug
> Components: cdi
> Affects Versions: 4.12.0.Final
> Environment: OS X 10.14.6
> Reporter: Zbyněk Červinka
> Assignee: Jeff MAURY
> Priority: Major
> Fix For: 4.13.0.Final
>
> Attachments: example_of_context_menu_which_is_present.png, missing_context_menu.png
>
>
> When running the BeansXMLCompletionTestCDI20.class, the Content Assist item in the Edit menu is being checked. See the "missing_context_menu.png" image in the attachment to see the situation and the missing Content Assist item in the Edit menu. Then see the "example_of_context_menu_which_is_present.png" - here is captured the situation where the Content Assist item is present.
--
This message was sent by Atlassian Jira
(v7.13.8#713008)
5 years, 1 month
[JBoss JIRA] (JBIDE-26750) Update CDI.itests to run on java 11 and add some parameters to the pom.xml
by Jeff MAURY (Jira)
[ https://issues.jboss.org/browse/JBIDE-26750?page=com.atlassian.jira.plugi... ]
Jeff MAURY updated JBIDE-26750:
-------------------------------
Fix Version/s: 4.13.0.Final
(was: 4.13.0.AM1)
> Update CDI.itests to run on java 11 and add some parameters to the pom.xml
> --------------------------------------------------------------------------
>
> Key: JBIDE-26750
> URL: https://issues.jboss.org/browse/JBIDE-26750
> Project: Tools (JBoss Tools)
> Issue Type: Task
> Components: cdi
> Affects Versions: 4.13.0.AM1
> Reporter: Zbyněk Červinka
> Assignee: Zbyněk Červinka
> Priority: Major
> Fix For: 4.13.0.Final
>
>
> *Description of the task from [~odockal]:*
> As I said some time ago, would be awesome to also have test project running on Java 11 in case that test are running on machine with jdk 11. Also, I can see that this condition repeats in every class, do you dare to extract it somewhere else and just call in @requirementResctriction annotated method?
> Let's put it into some utility class, that's an easiest solution.
> Update:
> I can image that server family and version would be parametrized in pom. One could have parameter ie. server.family and server.version and so any update to server and its version could happen in one place at once.
> And you can run test for both server eap and wildfly driven by param in jenkins.
--
This message was sent by Atlassian Jira
(v7.13.8#713008)
5 years, 1 month