[
https://issues.jboss.org/browse/JBDS-2669?page=com.atlassian.jira.plugin....
]
Nick Boldt updated JBDS-2669:
-----------------------------
Attachment: build1667.png
Build is blue again:
!build1667.png!
Changes in this build since last blue one:
{quote}
#1667 (Jan 28, 2014 9:33:43 AM)
merge in @dgolovin 's changes from JBDS-2862 to new namespace
com/jboss/devstudio/core/installer/PathSelectionPanel.java (JBDS-2669) (commit:
282b7262f0c542d2959c84914103a3caedf0f439) — nickboldt / detail
#1665 (Jan 28, 2014 4:49:49 AM)
[JBDS-2862] Let create target install folder during install (commit:
5c2fafc49d0793aa6bbac43a1def760c66d27129) — dgolovin / detail
JBDS-2669 refactor com.jboss.jbds -> com.jboss.devstudio; refactor
com.jboss.jbds.product (plugin) to com.jboss.devstudio.core; refactor com.jboss.jbds.all
to com.jboss.devstudio.core.package; etc. BUILDS OK LOCALLY w/ instructions in root
pom.xml, have not tested installation + run yet (commit:
9948ca6856900bf33c91f6231f853211d81de806) — nickboldt / detail
must add p2.inf instructions to support renamed features (for upgrading from Alpha1 to
Alpha2); also fix feature descriptions as com.jboss.devstudio.core.all should be
com.jboss.devstudio.core.package (commit: 8197e1be4fea38122181b40984a418c9a47df6c8) —
nickboldt / detail
due to changes in parent pom, need to add JBT aggregate site explicitly to the root
pom in order to resolve upstream JBT deps (commit:
a01a94f4247523d3434ca2045360ca514f4a153e) — nickboldt / detail
{quote}
rename/refactor JBDS product .feature / plugin / .product to have
less confusing names
--------------------------------------------------------------------------------------
Key: JBDS-2669
URL:
https://issues.jboss.org/browse/JBDS-2669
Project: Developer Studio (JBoss Developer Studio)
Issue Type: Bug
Security Level: Public(Everyone can see)
Components: build, installer, updatesite
Affects Versions: 7.0.0.GA
Reporter: Nick Boldt
Assignee: Nick Boldt
Priority: Critical
Fix For: 8.0.0.Alpha2
Attachments: build1667.png,
update-product-manually-with-refactoring-full-featureset-review.png,
update-product-manually-with-refactoring-full-featureset.png,
update-product-manually-with-refactoring.png
We should consider some better names for these artifacts so they collide less and are
more obvious which is which.
1.
https://github.com/jbdevstudio/jbdevstudio-product/blob/master/features/c...
** featureName=JBoss Developer Studio (Core Features) / BYOE category in update site
2.
https://github.com/jbdevstudio/jbdevstudio-product/blob/master/plugins/co...
and
https://github.com/jbdevstudio/jbdevstudio-product/blob/master/plugins/co...
** Bundle-SymbolicName: com.jboss.jbds.product;singleton:=true
3.
https://github.com/jbdevstudio/jbdevstudio-product/blob/master/site/com.j...
** name="JBoss Developer Studio (Branded Product)"
uid="com.jboss.jbds.all" id="com.jboss.jbds.product.product"
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see:
http://www.atlassian.com/software/jira