How different is that from the immutable Map? I find the Map more flexible in terms of:
- you can do inputs.keySet() and iterate through the input names (there are some places
where we do this)
- some UIProviders need to know if a Command has any input at all to decide if it should
execute or should render the Wizard screen.
So I am not sure if this is a good idea, but I may be wrong ;)
Em 19/02/2015, às 07:24, Antonio Goncalves
I'm investigating how to refactor UICommands in the best way (see the analysis in
). But before refactoring, I would like to add a
stronger test coverage so I make sure I don't break things.
I was looking at CommandController that list of the command inputs :
Map<String, InputComponent<?, ?>> getInputs();
I would like to add the following commands
InputComponent<?, ?> getInput(String input); // returns one input
boolean hasInput(String input); // checks if the input is present
What do you think ?
Software architect and Java Champion
Web site | Twitter | LinkedIn | Paris JUG | Devoxx France
forge-dev mailing list