]
Andre Dietisheim closed JBIDE-17879.
------------------------------------
closed since nothing for QE to verify
Remove "duplicate" code when checking project dirty state
---------------------------------------------------------
Key: JBIDE-17879
URL:
https://issues.jboss.org/browse/JBIDE-17879
Project: Tools (JBoss Tools)
Issue Type: Enhancement
Components: openshift
Affects Versions: 4.2.0.Beta3
Reporter: Andre Dietisheim
Assignee: Andre Dietisheim
Fix For: 4.2.0.CR1
We currently have duplicate code where we check a project for being dirty:
* EGitUtils#isDirty
* OpenShiftServerUtils#getCommittableChanges
They both use the same EGit means to get to know about the uncommitted changes but use a
different facade. We should unify those and make sure our API behaves the same.