Hi,
Just as an example of how badly we need #{cc.attrs.action} or
#{cc.attrs.actionListener} to work in JSF 2.1, here is a mail from the
myfaces-user-list from today (some parts are cut for clarity):
For example imagine a simple component that uses a commandLink and has two
attributes: "action" and "actionListener":
<cc:interface>
<cc:attribute name="action" method-signature="java.lang.String
action()"
default="???" />
<cc:attribute name="actionListener" method-signature="void
actionListener(javax.faces.event.ActionEvent)" default="???" />
</cc:interface>
<cc:implementation>
<tr:commandLink action="#{cc.attrs.action}"
actionListener="#{cc.attrs.actionListener}" />
</cc:implementation>
---> The users really expect this to work! Frankly I also do and I
guess everyone else agrees.
Regards,
Jakob
2010/10/27 Martin Marinschek <mmarinschek(a)apache.org>:
Hi Ed,
one more thing:
> For the record, this will not make it into JSF 2.1. Not becasue there
> was feedback on it after the deadline, but because we didn't have it on
> the 2.1 list to begin with.
your comments on the issue
https://javaserverfaces-spec-public.dev.java.net/issues/show_bug.cgi?id=755
indicate otherwise, see below:
------- Additional comments from edburns Sat May 15 14:54:38 +0000 2010 -------
These are targeted at 2.1.
------- Additional comments from edburns Tue Jun 8 20:17:32 +0000 2010 -------
triage
------- Additional comments from edburns Thu Jun 24 21:41:01 +0000 2010 -------
GlassFish 3.1 M6 at the latest.
This is important, and we thought it was on the list!
best regards,
Martin
--
Jakob Korherr
blog:
http://www.jakobk.com
twitter:
http://twitter.com/jakobkorherr
work:
http://www.irian.at