[JBoss JIRA] (RF-13626) Rename the BOM artifact
by Brian Leathem (JIRA)
[ https://issues.jboss.org/browse/RF-13626?page=com.atlassian.jira.plugin.s... ]
Brian Leathem updated RF-13626:
-------------------------------
Original Estimate: 15 minutes
Remaining Estimate: 15 minutes
> Rename the BOM artifact
> -----------------------
>
> Key: RF-13626
> URL: https://issues.jboss.org/browse/RF-13626
> Project: RichFaces
> Issue Type: Task
> Security Level: Public(Everyone can see)
> Reporter: Brian Leathem
> Fix For: 4.5.0.Alpha3
>
> Original Estimate: 15 minutes
> Remaining Estimate: 15 minutes
>
> I've implemented these changes here:
> https://github.com/richfaces/richfaces/tree/RF-13608-artifact-rename
> I'd also like to rename the BOM as part of this issue. Currently the BOM manages the following Dependency versions:
> {code}
> <dependencyManagement>
> <dependencies>
> <!-- Optional cache dependencies -->
> <dependency>
> <groupId>opensymphony</groupId>
> <artifactId>oscache</artifactId>
> <version>${version.oscache}</version>
> </dependency>
> <dependency>
> <groupId>org.jboss.cache</groupId>
> <artifactId>jbosscache-core</artifactId>
> <version>${version.jbosscache}</version>
> </dependency>
> <dependency>
> <groupId>net.sf.ehcache</groupId>
> <artifactId>ehcache</artifactId>
> <version>${version.ehcache}</version>
> </dependency>
> </dependencies>
> </dependencyManagement>
> {code}
> Since only the cache-dependencies are managed, we could rename the BOM to {{richfaces-cache-bom}}.
--
This message was sent by Atlassian JIRA
(v6.2.3#6260)
10 years, 6 months
[JBoss JIRA] (RF-13608) Apply appropriate package and artifact names to the component poms
by Brian Leathem (JIRA)
[ https://issues.jboss.org/browse/RF-13608?page=com.atlassian.jira.plugin.s... ]
Brian Leathem edited comment on RF-13608 at 5/8/14 12:36 PM:
-------------------------------------------------------------
The changes suggested in this comment is being track in a new issue RF-13626
----
{quote}
I've implemented these changes here:
https://github.com/richfaces/richfaces/tree/RF-13608-artifact-rename
I'd also like to rename the BOM as part of this issue. Currently the BOM manages the following Dependency versions:
{code}
<dependencyManagement>
<dependencies>
<!-- Optional cache dependencies -->
<dependency>
<groupId>opensymphony</groupId>
<artifactId>oscache</artifactId>
<version>${version.oscache}</version>
</dependency>
<dependency>
<groupId>org.jboss.cache</groupId>
<artifactId>jbosscache-core</artifactId>
<version>${version.jbosscache}</version>
</dependency>
<dependency>
<groupId>net.sf.ehcache</groupId>
<artifactId>ehcache</artifactId>
<version>${version.ehcache}</version>
</dependency>
</dependencies>
</dependencyManagement>
{code}
Since only the cache-dependencies are managed, we could rename the BOM to {{richfaces-cache-bom}}.
{quote}
was (Author: bleathem):
I've implemented these changes here:
https://github.com/richfaces/richfaces/tree/RF-13608-artifact-rename
I'd also like to rename the BOM as part of this issue. Currently the BOM manages the following Dependency versions:
{code}
<dependencyManagement>
<dependencies>
<!-- Optional cache dependencies -->
<dependency>
<groupId>opensymphony</groupId>
<artifactId>oscache</artifactId>
<version>${version.oscache}</version>
</dependency>
<dependency>
<groupId>org.jboss.cache</groupId>
<artifactId>jbosscache-core</artifactId>
<version>${version.jbosscache}</version>
</dependency>
<dependency>
<groupId>net.sf.ehcache</groupId>
<artifactId>ehcache</artifactId>
<version>${version.ehcache}</version>
</dependency>
</dependencies>
</dependencyManagement>
{code}
Since only the cache-dependencies are managed, we could rename the BOM to {{richfaces-cache-bom}}.
Thoughts?
> Apply appropriate package and artifact names to the component poms
> ------------------------------------------------------------------
>
> Key: RF-13608
> URL: https://issues.jboss.org/browse/RF-13608
> Project: RichFaces
> Issue Type: Task
> Security Level: Public(Everyone can see)
> Reporter: Brian Leathem
> Assignee: Brian Leathem
> Fix For: 4.5.0.Alpha3
>
> Original Estimate: 30 minutes
> Remaining Estimate: 30 minutes
>
> The current package {{org.richfaces.compat}} is inappropriate for the RichFaces 4.5 release.
--
This message was sent by Atlassian JIRA
(v6.2.3#6260)
10 years, 6 months
[JBoss JIRA] (RF-13626) Rename the BOM artifact
by Brian Leathem (JIRA)
Brian Leathem created RF-13626:
----------------------------------
Summary: Rename the BOM artifact
Key: RF-13626
URL: https://issues.jboss.org/browse/RF-13626
Project: RichFaces
Issue Type: Task
Security Level: Public (Everyone can see)
Reporter: Brian Leathem
Fix For: 4.5.0.Alpha3
I've implemented these changes here:
https://github.com/richfaces/richfaces/tree/RF-13608-artifact-rename
I'd also like to rename the BOM as part of this issue. Currently the BOM manages the following Dependency versions:
{code}
<dependencyManagement>
<dependencies>
<!-- Optional cache dependencies -->
<dependency>
<groupId>opensymphony</groupId>
<artifactId>oscache</artifactId>
<version>${version.oscache}</version>
</dependency>
<dependency>
<groupId>org.jboss.cache</groupId>
<artifactId>jbosscache-core</artifactId>
<version>${version.jbosscache}</version>
</dependency>
<dependency>
<groupId>net.sf.ehcache</groupId>
<artifactId>ehcache</artifactId>
<version>${version.ehcache}</version>
</dependency>
</dependencies>
</dependencyManagement>
{code}
Since only the cache-dependencies are managed, we could rename the BOM to {{richfaces-cache-bom}}.
--
This message was sent by Atlassian JIRA
(v6.2.3#6260)
10 years, 6 months
[JBoss JIRA] (RF-13608) Apply appropriate package and artifact names to the component poms
by Brian Leathem (JIRA)
[ https://issues.jboss.org/browse/RF-13608?page=com.atlassian.jira.plugin.s... ]
Brian Leathem resolved RF-13608.
--------------------------------
Resolution: Done
Unit tests pass, and integration tests fail at the same place. I've gone ahead and merged this branch into 4.5.x. Any adjustments to the artifact/folder naming can be raised in a new issue.
> Apply appropriate package and artifact names to the component poms
> ------------------------------------------------------------------
>
> Key: RF-13608
> URL: https://issues.jboss.org/browse/RF-13608
> Project: RichFaces
> Issue Type: Task
> Security Level: Public(Everyone can see)
> Reporter: Brian Leathem
> Assignee: Brian Leathem
> Fix For: 4.5.0.Alpha3
>
> Original Estimate: 30 minutes
> Remaining Estimate: 30 minutes
>
> The current package {{org.richfaces.compat}} is inappropriate for the RichFaces 4.5 release.
--
This message was sent by Atlassian JIRA
(v6.2.3#6260)
10 years, 6 months
[JBoss JIRA] (RF-13611) RichFaces 5.0.0.Alpha3 doesn't work with Weld 2.2.0.Final
by Juergen Zimmermann (JIRA)
[ https://issues.jboss.org/browse/RF-13611?page=com.atlassian.jira.plugin.s... ]
Juergen Zimmermann commented on RF-13611:
-----------------------------------------
Now the WildFly snapshots for 8.1.0 are upgraded to Weld 2.2.0.SP1. Therefore, RichFaces won't work with the upcoming release of WildFly...
> RichFaces 5.0.0.Alpha3 doesn't work with Weld 2.2.0.Final
> ---------------------------------------------------------
>
> Key: RF-13611
> URL: https://issues.jboss.org/browse/RF-13611
> Project: RichFaces
> Issue Type: Bug
> Security Level: Public(Everyone can see)
> Components: component-push/poll
> Affects Versions: 5.0.0.Alpha3
> Reporter: Juergen Zimmermann
> Fix For: 4.5-Tracking
>
>
> I'm using WildFly 8.0.0.CR1 and Weld 2.2.0.Final (via the WildFly patch mechanism). However, I'm getting the stacktrace below. When I patch WildFly 8.0.0.CR1 with the predecessor version Weld 2.2.0.CR2, then the issue is gone.
> {code}
> ERROR [org.jboss.msc.service.fail] MSC000001: Failed to start service jboss.deployment.unit."shop.war".WeldStartService: org.jboss.msc.service.StartException in service jboss.deployment.unit."shop.war".WeldStartService: Failed to start service
> at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1904) [jboss-msc-1.2.2.Final.jar:1.2.2.Final]
> at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142) [rt.jar:1.8.0]
> at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) [rt.jar:1.8.0]
> at java.lang.Thread.run(Thread.java:744) [rt.jar:1.8.0]
> Caused by: org.jboss.weld.exceptions.DefinitionException: Exception List with 1 exceptions:
> Exception 0 :
> org.jboss.weld.exceptions.DefinitionException: WELD-000412: ObserverMethod.getReception() returned null for org.richfaces.push.cdi.PushCDIExtension$PushObserverMethod@31e23242
> at org.jboss.weld.util.Observers.validateObserverMethod(Observers.java:118)
> at org.jboss.weld.bootstrap.events.AfterBeanDiscoveryImpl.addObserverMethod(AfterBeanDiscoveryImpl.java:158)
> at org.richfaces.push.cdi.PushCDIExtension.afterBeanDiscovery(PushCDIExtension.java:99)
> at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
> at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
> at java.lang.reflect.Method.invoke(Method.java:483)
> at org.jboss.weld.injection.MethodInjectionPoint.invokeOnInstanceWithSpecialValue(MethodInjectionPoint.java:90)
> at org.jboss.weld.event.ObserverMethodImpl.sendEvent(ObserverMethodImpl.java:271)
> at org.jboss.weld.event.ExtensionObserverMethodImpl.sendEvent(ExtensionObserverMethodImpl.java:121)
> at org.jboss.weld.event.ObserverMethodImpl.sendEvent(ObserverMethodImpl.java:258)
> at org.jboss.weld.event.ObserverMethodImpl.notify(ObserverMethodImpl.java:237)
> at org.jboss.weld.event.ObserverNotifier.notifyObserver(ObserverNotifier.java:174)
> at org.jboss.weld.event.ObserverNotifier.notifyObservers(ObserverNotifier.java:133)
> at org.jboss.weld.event.ObserverNotifier.fireEvent(ObserverNotifier.java:107)
> at org.jboss.weld.bootstrap.events.AbstractContainerEvent.fire(AbstractContainerEvent.java:54)
> at org.jboss.weld.bootstrap.events.AbstractDefinitionContainerEvent.fire(AbstractDefinitionContainerEvent.java:42)
> at org.jboss.weld.bootstrap.events.AfterBeanDiscoveryImpl.fire(AfterBeanDiscoveryImpl.java:59)
> at org.jboss.weld.bootstrap.WeldStartup.deployBeans(WeldStartup.java:393)
> at org.jboss.weld.bootstrap.WeldBootstrap.deployBeans(WeldBootstrap.java:83)
> at org.jboss.as.weld.WeldStartService.start(WeldStartService.java:92)
> at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1948)
> at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1881)
> at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
> at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
> at java.lang.Thread.run(Thread.java:744)
> at org.jboss.weld.bootstrap.events.AbstractDefinitionContainerEvent.fire(AbstractDefinitionContainerEvent.java:44)
> at org.jboss.weld.bootstrap.events.AfterBeanDiscoveryImpl.fire(AfterBeanDiscoveryImpl.java:59)
> at org.jboss.weld.bootstrap.WeldStartup.deployBeans(WeldStartup.java:393)
> at org.jboss.weld.bootstrap.WeldBootstrap.deployBeans(WeldBootstrap.java:83)
> at org.jboss.as.weld.WeldStartService.start(WeldStartService.java:92)
> at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1948) [jboss-msc-1.2.2.Final.jar:1.2.2.Final]
> at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1881) [jboss-msc-1.2.2.Final.jar:1.2.2.Final]
> ... 3 more
> {code}
--
This message was sent by Atlassian JIRA
(v6.2.3#6260)
10 years, 6 months
[JBoss JIRA] (RF-13608) Apply appropriate package and artifact names to the component poms
by Brian Leathem (JIRA)
[ https://issues.jboss.org/browse/RF-13608?page=com.atlassian.jira.plugin.s... ]
Brian Leathem commented on RF-13608:
------------------------------------
I've implemented these changes here:
https://github.com/richfaces/richfaces/tree/RF-13608-artifact-rename
I'd also like to rename the BOM as part of this issue. Currently the BOM manages the following Dependency versions:
{code}
<dependencyManagement>
<dependencies>
<!-- Optional cache dependencies -->
<dependency>
<groupId>opensymphony</groupId>
<artifactId>oscache</artifactId>
<version>${version.oscache}</version>
</dependency>
<dependency>
<groupId>org.jboss.cache</groupId>
<artifactId>jbosscache-core</artifactId>
<version>${version.jbosscache}</version>
</dependency>
<dependency>
<groupId>net.sf.ehcache</groupId>
<artifactId>ehcache</artifactId>
<version>${version.ehcache}</version>
</dependency>
</dependencies>
</dependencyManagement>
{code}
Since only the cache-dependencies are managed, we could rename the BOM to {{richfaces-cache-bom}}.
Thoughts?
> Apply appropriate package and artifact names to the component poms
> ------------------------------------------------------------------
>
> Key: RF-13608
> URL: https://issues.jboss.org/browse/RF-13608
> Project: RichFaces
> Issue Type: Task
> Security Level: Public(Everyone can see)
> Reporter: Brian Leathem
> Assignee: Brian Leathem
> Fix For: 4.5.0.Alpha3
>
> Original Estimate: 30 minutes
> Remaining Estimate: 30 minutes
>
> The current package {{org.richfaces.compat}} is inappropriate for the RichFaces 4.5 release.
--
This message was sent by Atlassian JIRA
(v6.2.3#6260)
10 years, 6 months
[JBoss JIRA] (RF-13608) Apply appropriate package and artifact names to the component poms
by Brian Leathem (JIRA)
[ https://issues.jboss.org/browse/RF-13608?page=com.atlassian.jira.plugin.s... ]
Brian Leathem edited comment on RF-13608 at 5/7/14 1:06 PM:
------------------------------------------------------------
After discussing this with [~lfryc] we have come up with the following artifact/naming convention:
* The rich set of components will be called:
** {{org.richfaces}}:{{richfaces}}
* The a4j set of components will be called:
** {{org.richfaces}}:{{richfaces-a4j}}
* The richfaces core will be called:
** {{org.richfaces}}:{{richfaces-core}}
This naming convention was chosen so that we can setup the following transitive dependencies
* {{richfaces}} depends upon
** {{richfaces-a4j}} (this is where the old [4.3 common module|https://github.com/richfaces4/components/tree/master/common] landed)
** {{richfaces-core}}
* {{richfaces-a4j}} depends upon
** {{richfaces-core}}
With these transitive dependencies in place, an application developer needs only include the single dependency in there application:
{code}
<dependency>
<groupId>org.richfaces</groupId>
<artifactId>richfaces</artifactId>
</dependency>
{code}
Additionally the choice of artifact names will give meaningful names for those who consume the artifacts directly (without using maven).
was (Author: bleathem):
After discussing this with [~lfryc] we have come up with the following artifact/naming convention:
* The rich set of components will be called:
** {{org.richfaces}}:{{richfaces}}
* The a4j set of components will be called:
** {{org.richfaces}}:{{richfaces-a4j}}
* The richfaces core will be called:
** {{org.richfaces}}:{{richfaces-core}}
This naming convention was chosen so that we can setup the following transitive dependencies
* {{richfaces}} depends upon
** {{richfaces-a4j}}
** {{richfaces-core}}
* {{richfaces-a4j}} depends upon
** {{richfaces-core}}
With these transitive dependencies in place, an application developer needs only include the single dependency in there application:
{code}
<dependency>
<groupId>org.richfaces</groupId>
<artifactId>richfaces</artifactId>
</dependency>
{code}
Additionally the choice of artifact names will give meaningful names for those who consume the artifacts directly (without using maven).
> Apply appropriate package and artifact names to the component poms
> ------------------------------------------------------------------
>
> Key: RF-13608
> URL: https://issues.jboss.org/browse/RF-13608
> Project: RichFaces
> Issue Type: Task
> Security Level: Public(Everyone can see)
> Reporter: Brian Leathem
> Assignee: Brian Leathem
> Fix For: 4.5.0.Alpha3
>
> Original Estimate: 30 minutes
> Remaining Estimate: 30 minutes
>
> The current package {{org.richfaces.compat}} is inappropriate for the RichFaces 4.5 release.
--
This message was sent by Atlassian JIRA
(v6.2.3#6260)
10 years, 6 months
[JBoss JIRA] (RF-13608) Apply appropriate package and artifact names to the component poms
by Brian Leathem (JIRA)
[ https://issues.jboss.org/browse/RF-13608?page=com.atlassian.jira.plugin.s... ]
Brian Leathem commented on RF-13608:
------------------------------------
After discussing this with [~lfryc] we have come up with the following artifact/naming convention:
* The rich set of components will be called:
** {{org.richfaces}}:{{richfaces}}
* The a4j set of components will be called:
** {{org.richfaces}}:{{richfaces-a4j}}
* The richfaces core will be called:
** {{org.richfaces}}:{{richfaces-core}}
This naming convention was chosen so that we can setup the following transitive dependencies
* {{richfaces}} depends upon
** {{richfaces-a4j}}
** {{richfaces-core}}
* {{richfaces-a4j}} depends upon
** {{richfaces-core}}
With these transitive dependencies in place, an application developer needs only include the single dependency in there application:
{code}
<dependency>
<groupId>org.richfaces</groupId>
<artifactId>richfaces</artifactId>
</dependency>
{code}
Additionally the choice of artifact names will give meaningful names for those who consume the artifacts directly (without using maven).
> Apply appropriate package and artifact names to the component poms
> ------------------------------------------------------------------
>
> Key: RF-13608
> URL: https://issues.jboss.org/browse/RF-13608
> Project: RichFaces
> Issue Type: Task
> Security Level: Public(Everyone can see)
> Reporter: Brian Leathem
> Assignee: Brian Leathem
> Fix For: 4.5.0.Alpha3
>
> Original Estimate: 30 minutes
> Remaining Estimate: 30 minutes
>
> The current package {{org.richfaces.compat}} is inappropriate for the RichFaces 4.5 release.
--
This message was sent by Atlassian JIRA
(v6.2.3#6260)
10 years, 6 months
[JBoss JIRA] (RF-13625) org.ajax4jsf.model.SequenceRange is not serializable
by Marco Rossi (JIRA)
Marco Rossi created RF-13625:
--------------------------------
Summary: org.ajax4jsf.model.SequenceRange is not serializable
Key: RF-13625
URL: https://issues.jboss.org/browse/RF-13625
Project: RichFaces
Issue Type: Bug
Security Level: Public (Everyone can see)
Affects Versions: 4.3.6
Reporter: Marco Rossi
Caused by: org.infinispan.marshall.NotSerializableException: org.ajax4jsf.model.SequenceRange
Caused by: an exception which occurred:
in field cachedRange
in field bean
in object java.util.HashMap@0
in object org.jboss.as.clustering.SimpleMarshalledValue@0
in object org.infinispan.atomic.PutOperation@0
in object java.util.LinkedList@0
in object org.infinispan.atomic.AtomicHashMapDelta@3e01b8
in object org.infinispan.commands.write.PutKeyValueCommand@514bdbf9
in object org.infinispan.commands.tx.PrepareCommand@8bb71fb
--
This message was sent by Atlassian JIRA
(v6.2.3#6260)
10 years, 6 months