[
https://issues.jboss.org/browse/RF-13608?page=com.atlassian.jira.plugin.s...
]
Brian Leathem edited comment on RF-13608 at 5/8/14 12:36 PM:
-------------------------------------------------------------
The changes suggested in this comment is being track in a new issue RF-13626
----
{quote}
I've implemented these changes here:
https://github.com/richfaces/richfaces/tree/RF-13608-artifact-rename
I'd also like to rename the BOM as part of this issue. Currently the BOM manages the
following Dependency versions:
{code}
<dependencyManagement>
<dependencies>
<!-- Optional cache dependencies -->
<dependency>
<groupId>opensymphony</groupId>
<artifactId>oscache</artifactId>
<version>${version.oscache}</version>
</dependency>
<dependency>
<groupId>org.jboss.cache</groupId>
<artifactId>jbosscache-core</artifactId>
<version>${version.jbosscache}</version>
</dependency>
<dependency>
<groupId>net.sf.ehcache</groupId>
<artifactId>ehcache</artifactId>
<version>${version.ehcache}</version>
</dependency>
</dependencies>
</dependencyManagement>
{code}
Since only the cache-dependencies are managed, we could rename the BOM to
{{richfaces-cache-bom}}.
{quote}
was (Author: bleathem):
I've implemented these changes here:
https://github.com/richfaces/richfaces/tree/RF-13608-artifact-rename
I'd also like to rename the BOM as part of this issue. Currently the BOM manages the
following Dependency versions:
{code}
<dependencyManagement>
<dependencies>
<!-- Optional cache dependencies -->
<dependency>
<groupId>opensymphony</groupId>
<artifactId>oscache</artifactId>
<version>${version.oscache}</version>
</dependency>
<dependency>
<groupId>org.jboss.cache</groupId>
<artifactId>jbosscache-core</artifactId>
<version>${version.jbosscache}</version>
</dependency>
<dependency>
<groupId>net.sf.ehcache</groupId>
<artifactId>ehcache</artifactId>
<version>${version.ehcache}</version>
</dependency>
</dependencies>
</dependencyManagement>
{code}
Since only the cache-dependencies are managed, we could rename the BOM to
{{richfaces-cache-bom}}.
Thoughts?
Apply appropriate package and artifact names to the component poms
------------------------------------------------------------------
Key: RF-13608
URL:
https://issues.jboss.org/browse/RF-13608
Project: RichFaces
Issue Type: Task
Security Level: Public(Everyone can see)
Reporter: Brian Leathem
Assignee: Brian Leathem
Fix For: 4.5.0.Alpha3
Original Estimate: 30 minutes
Remaining Estimate: 30 minutes
The current package {{org.richfaces.compat}} is inappropriate for the RichFaces 4.5
release.
--
This message was sent by Atlassian JIRA
(v6.2.3#6260)