[
https://issues.jboss.org/browse/RF-10712?page=com.atlassian.jira.plugin.s...
]
Martin Kočí commented on RF-10712:
----------------------------------
Hi Nick&others, I took a quick look on events from richfaces and here are my
suggestions:
TreeSelectionChangeListener - has method processSelectionChange, should be
processTreeSelectionChange, this is related to missing "SelectionChange" event,
listener, ...: RF-10439
DataScrollerListener - "DataScroller" vs "DataScroll" - isn't the
core operation characterised with this event "DataScroll" in a iterable
component? like UIData.setFirst(100), UIData.setRows(100)
TreeToggleListener - similar like TreeSelectionChangeListener, has method processToggle
method, but there is the ToggleListener.processToggle already! PanelToggleListener has
correct name of method: PanelToggleListener.processPanelToggle
ValidatorListener - isn't this listener to "validation", not validator? Has
method processValidation. Is this something special between PreValidateEvent and
PostValidateEvent ?
processUpload vs. processFileUpload - naming conventions
--------------------------------------------------------
Key: RF-10712
URL:
https://issues.jboss.org/browse/RF-10712
Project: RichFaces
Issue Type: Feature Request
Security Level: Public(Everyone can see)
Components: compatibility
Affects Versions: 4.0.0.CR1
Environment: richfaces 4.0.X branch
Reporter: Martin Kočí
Assignee: Konstantin Mishin
Fix For: 4.0.0.Final
method org.richfaces.event.FileUploadListener.processUpload(FileUploadEvent) should be
FileUploadListener.processFileUpload - with the "File" word in the middle.
The unspecified JSF convention is:
* logical name ("FileUpload")
* listener: logical name + "Listener" ("FileUploadListener")
* event: logical name + "Event" ("FileUploadEvent")
* method "process" + logical name ("processFileUpload")
--
This message is automatically generated by JIRA.
For more information on JIRA, see:
http://www.atlassian.com/software/jira