I am not a big fan of the retval which reminds me of Gollum skeaping his
name ;)
- <return value>
- <return>
- (return value)
- (return)
I think I like <return value> the best.
As Hardy said, the name is not critical as nodes are identified by their
elementDescriptor.kind.
Emmanuel
On Fri 2013-02-08 11:19, Matt Benson wrote:
I am somewhat attracted to Sebastian's suggestion of illegal
identifier
characters. My suggestion would be "<result>".
Matt
On Fri, Feb 8, 2013 at 9:21 AM, Hardy Ferentschik <hardy(a)hibernate.org>wrote:
> I don't want to introduce a name for the return value to allow things like
>
> if(node.getName.equals("retval")) {
> ReturnValueDescriptor descriptor = (ReturnValueDescriptor)
> node.getElementDescriptor();
> }
>
> The actual type of a node is still given by it ElementDescriptor. The name
> cannot be used for that. It is more for convenience
> and "nice" toString implementation. Yes it could be ambiguous, but I
don't
> think it matters. Any code relying on the property path
> as string is potentially wrong anyways. A white space seems odd,
> especially in the light of toString.
>
> In that light $retval might be a legal java identifier, but chances are
> slim someone uses it.
>
> --Hardy
>
>
> On 8 Jan 2013, at 4:07 PM, Sebastian Thomschke <sebastian.thomschke(a)web.de>
> wrote:
>
> > What if there is a property or method called "returnValue"? I think
the
> constant string returned should contain a character that is not legal for
> java identifier names. E.g. a white space.
> >
> > seb
> >
> > On 08.02.2013 12:51, Gunnar Morling wrote:
> >> Experts,
> >>
> >> another issue where we need some feedback is BVAL-368, which is about
> the name of path nodes representing return values.
> >>
> >> As per the current draft, Node#getName() returns null in that case.
> Question is, whether we should return something more meaningful, and if so,
> which value.
> >>
> >> The RI used to return "$retval" before we change this to match
the
> spec. Another obvious option would be "returnValue". Having a
standardized
> node name for return value nodes would also help with better toString()
> implementations for j.v.Path (although that's not standardized).
> >>
> >> Any thoughts?
> >>
> >> Thanks,
> >>
> >> --Gunnar
> >>
> >> [1]
https://hibernate.onjira.com/browse/BVAL-368
> >>
> >>
> >> _______________________________________________
> >> beanvalidation-dev mailing list
> >>
> >> beanvalidation-dev(a)lists.jboss.org
> >>
https://lists.jboss.org/mailman/listinfo/beanvalidation-dev
> >
> > _______________________________________________
> > beanvalidation-dev mailing list
> > beanvalidation-dev(a)lists.jboss.org
> >
https://lists.jboss.org/mailman/listinfo/beanvalidation-dev
>
>
> _______________________________________________
> beanvalidation-dev mailing list
> beanvalidation-dev(a)lists.jboss.org
>
https://lists.jboss.org/mailman/listinfo/beanvalidation-dev
>
_______________________________________________
beanvalidation-dev mailing list
beanvalidation-dev(a)lists.jboss.org
https://lists.jboss.org/mailman/listinfo/beanvalidation-dev