Branch: refs/heads/master
Home:
https://github.com/hibernate/hibernate-orm
Commit: a9fdc1239a3a6cdacc86317f31158324fa6a3149
https://github.com/hibernate/hibernate-orm/commit/a9fdc1239a3a6cdacc86317...
Author: Yoann Rodière <yoann(a)hibernate.org>
Date: 2018-07-17 (Tue, 17 Jul 2018)
Changed paths:
M hibernate-core/src/main/java/org/hibernate/internal/SessionImpl.java
M hibernate-core/src/test/java/org/hibernate/jpa/test/query/AddNamedQueryTest.java
Log Message:
-----------
HHH-12795 Use the exact flush mode specified in @NamedQuery/@NamedNativeQuery when
instantiating named queries
... instead of using an approximation in terms of JPA flush mode.
Commit: a0e6d86052803bd4eae7c8abc968e7a92954c66f
https://github.com/hibernate/hibernate-orm/commit/a0e6d86052803bd4eae7c8a...
Author: Yoann Rodière <yoann(a)hibernate.org>
Date: 2018-07-17 (Tue, 17 Jul 2018)
Changed paths:
A
hibernate-core/src/test/java/org/hibernate/jpa/test/query/NamedQueryFlushModeTest.java
Log Message:
-----------
HHH-12795 Test the flushMode attribute of @NamedQuery and @NamedNativeQuery
Commit: 523b29af0481b19b3b477eafbe04b854f7fc60da
https://github.com/hibernate/hibernate-orm/commit/523b29af0481b19b3b477ea...
Author: Yoann Rodière <yoann(a)hibernate.org>
Date: 2018-07-17 (Tue, 17 Jul 2018)
Changed paths:
M hibernate-core/src/main/java/org/hibernate/internal/SessionImpl.java
Log Message:
-----------
HHH-12795 Remove duplicate code from SessionImpl
SessionImpl.initQueryFromNamedDefinition calls its super implementation
AbstractSharedSessionContract.initQueryFromNamedDefinition, which
already does a lot of the work performed in
SessionImpl.initQueryFromNamedDefinition.
The only difference is that SessionImpl uses hints to set values on the
query, whereas AbstractSharedSessionContract uses direct calls to
setters. But that should produce the same result, since setHint() just
delegates to the setters.
Only one thing was done in SessionImpl but not in
AbstractSharedSessionContract: lock mode handling.
I left it in SessionImpl since moving it to the superclass would also
affect other subclasses such as StatelessSession or OGM sessions, and I
certainly don't want to change any behavior without further
investigation.
Compare:
https://github.com/hibernate/hibernate-orm/compare/fa02d1c65ff3...523b29a...
**NOTE:** This service been marked for deprecation:
https://developer.github.com/changes/2018-04-25-github-services-deprecation/
Functionality will be removed from
GitHub.com on January 31st, 2019.