"thomas.diesler(a)jboss.com" wrote : Thanks for your comments, but what should it
actually be?
|
| #1
| ProcessDefinition + Process
|
| #2
| ProcessDefinition + ProcessInstance
|
| #3
| something else completely
|
| Please also consider the usage of these artefacts
|
|
| | ProcessDefinitionService pdService =
engine.getService(ProcessDefinitionService.class);
| |
| | ProcessDefinition procDef = pdService.createProcessDefinition(XML);
| | Process proc = procDef.newProcess();
| |
| | Token tok = proc.startProcess();
| |
|
| vs.
|
|
| | ProcessDefinitionService pdService =
engine.getService(ProcessDefinitionService.class);
| |
| | ProcessDefinition procDef = pdService.createProcessDefinition(XML);
| | ProcessInstance procInst = procDef.newProcessInstance();
| |
| | Token tok = procInst.startProcessInstance();
| |
|
| Generally, please come up with an alternative suggestion if a given proposal is no
good for some reason i.e. I don't like Foo because ... Instead I propose Bar
|
I think #1 works fine. From my point of view, even for business people when they mention
"Process", they can mean both. Because for business people, they do not
differentiate between definition and "instance". They think that they draw a
diagram and the process is up like magic.
View the original post :
http://www.jboss.com/index.html?module=bb&op=viewtopic&p=4190250#...
Reply to the post :
http://www.jboss.com/index.html?module=bb&op=posting&mode=reply&a...