[
https://issues.jboss.org/browse/RF-12249?page=com.atlassian.jira.plugin.s...
]
Lukáš Fryč commented on RF-12249:
---------------------------------
So I have found two issues:
{code:java}
@Attribute
abstract public Boolean getCloseable();
{code}
generates
{code}
public Boolean isCloseable() {
Boolean value = (Boolean) getStateHelper().eval(Properties.closeable);
return value;
}
{code}
but the generated method should be named {{getCloseable}} in case of {{Boolean}}.
----
The similar (but no so severe) issues happen when {{boolean}} method defined:
{code:java}
@Attribute
abstract public boolean getCloseable();
{code}
generates
{code:java}
public boolean isCloseable() {
Boolean value = (Boolean) getStateHelper().eval(Properties.closeable, false);
return value;
}
{code}
but specification does not require to provide {{isCloseable}} - the {{getCloseable}}
method is no generated at all.
CDK: generate both get* and is* methods for boolean/Boolean
expressions
-----------------------------------------------------------------------
Key: RF-12249
URL:
https://issues.jboss.org/browse/RF-12249
Project: RichFaces
Issue Type: Bug
Security Level: Public(Everyone can see)
Components: cdk
Affects Versions: 4.2.0.Final
Reporter: Paul Dijou
Assignee: Lukáš Fryč
Priority: Critical
Fix For: 4.3.0.Milestone1
Generate both "get..." and "is..." method for Boolean and boolean
attributes
If you have an attribute like :
{code:java}
@Attribute
abstract public boolean isClosable();
{code}
This will generate a "isClosable()" method of course. But, then, trying to
access it in a template like :
{code:xml}
<c:if test="#{alert.closable}">
{code}
Will crash since JSF try to call the "getClosable()" method. The workaround is
to write :
{code:xml}
<c:if test="#{alert.isClosable()}">
{code}
But it would be nicer if the "geClosable()" method was generated in the same
time of the "isClosable()" method.
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:
https://issues.jboss.org/secure/ContactAdministrators!default.jspa
For more information on JIRA, see:
http://www.atlassian.com/software/jira