We now have javax.validation.ElementKind
which unfortunately clashes with the JDK ElementKind class.
Constrained and Validated prefixes do not work as technically we could
have non constrained (maybe non constrainable elements) in this enum as
we use it to describe Node kinds.
Anyone with a good name idea, go go go!
Emmanuel
On Mon 2013-02-11 14:26, Gunnar Morling wrote:
Experts,
Currently the enumeration Kind (as returned by ElementDescriptor#getKind())
is an inner enum of the ElementDescriptor interface.
In order to allow for its future re-use in other contexts, independent from
element descriptors, it seems reasonable to make this a top-level type.
Unfortunately the natural names, ElementKind and ElementType are taken by
JDK types, and if possible we should avoid a collision with these.
Candidates are
* ConstrainedElementKind
* ValidatedElementKind
Any preferences or other suggestions?
Thanks,
--Gunnar
_______________________________________________
beanvalidation-dev mailing list
beanvalidation-dev(a)lists.jboss.org
https://lists.jboss.org/mailman/listinfo/beanvalidation-dev