]
Manik Surtani resolved JBCACHE-1219.
------------------------------------
Resolution: Done
Refactor logic implementation of interceptors
---------------------------------------------
Key: JBCACHE-1219
URL:
http://jira.jboss.com/jira/browse/JBCACHE-1219
Project: JBoss Cache
Issue Type: Sub-task
Security Level: Public(Everyone can see)
Reporter: Manik Surtani
Assigned To: Mircea Markus
Fix For: 2.1.0.GA
The current interceptor implementations are pretty messy, unreadable and hard to
maintain, with lots of switches and casts from an args array.
The goal of this task is to create a SwitchedInterceptor, an abstract class that extends
Interceptor, which would perform a switch() and call no-op handlers which can be
overridden by subclasses such as the PessimisticLockInterceptor, etc. The benefit is that
the implementation interceptors are easier to follow through, read and refactor. Another
benefit is that the switched interceptor can take care of extracting method call
parameters and pass them to the handlers - making them typed.
--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: