The problem with this kind of syntax:
<activity type="mail"/>
is that you can't define a schema anymore. The content type of the activity element
has to allow any element.
One solution is to use nested subelements:
<activity>
| <mail to='boss' />
| </activity>
However, this is verbose and makes the process definition less readable.
WS-BPEL solved this by having a number of stock activities like:
<bpel:invoke operation="selfdestruct" />
and providing a placeholder for extension activities:
<bpel:extensionActivity>
| <jbpm:mail to='boss' />
| </bpel:extensionActivity>
The BPEL approach may be worth considering here.
@Heiko: the earlier posts were about skipping validation for user-defined extension items
whose schema was unavailable. Just FYI.
View the original post :
http://www.jboss.com/index.html?module=bb&op=viewtopic&p=4161629#...
Reply to the post :
http://www.jboss.com/index.html?module=bb&op=posting&mode=reply&a...