A couple more minor changes:
* Allow defaulting of value member of @New annotation 3.10
* rename getDeclaringBean() to getBean() to account for specialization
* override getBean() with correct type parameter on ManagedBean, ProducerBean
On Sat, May 23, 2009 at 10:30 AM, Gavin King <gavin.king(a)gmail.com> wrote:
I managed to cut a whole page from the spec by rationalizing some
scattered stuff into 7.1.
On Sat, May 23, 2009 at 1:28 AM, Gavin King <gavin.king(a)gmail.com> wrote:
> I've finished updating the SPI to reflect some of the things we've
> been discussing:
>
> * Extensions are now injectable 11.5
> * there are now subclasses of ProcessBean for different kinds of beans 11.5.7
> * addBean() and addObserver() now fire events 11.2.7, 11.2.8
> * I have clarified assignability for parameterized event types 11.3.1
> * Event.removeObserver() 10.4.1
> * Observer.notify() now returns boolean 10.2
>
> From my point of view, I would now be happy to submit the PFD, since
> my list of critical issues is now exhausted.
>
> So now's the time to:
>
> * review the spec for errors!
> * speak up if you have issues that have not been addressed!
>
> --
> Gavin King
> gavin.king(a)gmail.com
>
http://in.relation.to/Bloggers/Gavin
>
http://hibernate.org
>
http://seamframework.org
>
--
Gavin King
gavin.king(a)gmail.com
http://in.relation.to/Bloggers/Gavin
http://hibernate.org
http://seamframework.org
--
Gavin King
gavin.king(a)gmail.com
http://in.relation.to/Bloggers/Gavin
http://hibernate.org
http://seamframework.org