My vote is for #hasConstrainedParameters().
On Thu, Feb 28, 2013 at 7:59 AM, Rich Midwinter <rich.midwinter(a)gmail.com>wrote:
Perhaps worth mentioning we have BeanDescriptor#isBeanConstrained()
1.0. So at first glance I'd probably suggest isParameterConstrained() and
On Thursday, 28 February 2013, Gunnar Morling <gunnar(a)hibernate.org>
> Hi all,
> Hardy and I were wondering whether the method
name ExecutableDescriptor#areParametersConstrained() is the best choice.
> The name seems a bit unintuitive, when e.g. looking via auto-completion
for boolean getter methods which typically start with "is" or "has".
> * "isParameterConstrained()" (as in "is constrained on at least one
> * "hasConstrainedParameters()" would be better alternatives?
> The latter would also nicely match with
beanvalidation-dev mailing list